Easy Game


查看 提交 统计 提问
总时间限制: 1000ms 内存限制: 32768kB
描述
Fat brother(胖哥) and Maze(梅兹) are playing a kindof special game on a string S. Now they would like to count the length of this string. But as both Fat brother and Maze are programmers, they can recognize only two numbers 0 and 1. So instead of judging the length of this string, they decide to judge whether this number is even(偶数).


输入
The first line of the data is an integer T, which is the number of the text cases.
Then T cases follow, each case contains a line describe the string S in the treasure map. Now that S only contains lower case letters.
1 <= T <= 100, the length of the string is less than 10086
输出
For each case, output the case number first, and then output “Odd” 
if the length of S is odd, otherwise just output “Even”.
样例输入
4
Well
Thisisthesimplest
problem 
inthiscontest
样例输出
Case 1: Even
Case 2: Odd 
Case 3: Odd 
Case 4: Odd
来源

第四届福建省大学生程序设计竞赛



#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

char a[20000];

int main()
{
	int nc;
	cin >> nc;
	for(int i = 0 ; i < nc ; i++)
	{
		scanf("%s",a);
		cout << "Case " << i + 1 << ": ";
		if(strlen(a)%2)
			cout<<"Odd"<<endl;
		else
			cout<<"Even"<<endl;
		
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值