1141. PAT Ranking of Institutions (25)

1141. PAT Ranking of Institutions (25)

时间限制
500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where "ID" is a string of 6 characters with the first one representing the test level: "B" stands for the basic level, "A" the advanced level and "T" the top level; "Score" is an integer in [0, 100]; and "School" is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that "ID" is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where "Rank" is the rank (start from 1) of the institution; "School" is the institution code (all in lower case); "TWS" is the total weighted scorewhich is defined to be the integer part of "ScoreB/1.5 + ScoreA + ScoreT*1.5", where "ScoreX" is the total score of the testees belong to this institution on level X; and "Ns" is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2

4 lanx 81 2

这道题在考试的时候只能拿20分。

首先在对测试数据进行处理的时候采用了二重循环,结果最后两个点超时

修改后输出数据采用cout也超时了,以后要少用!

最后终于通过,但是时间超太久了

以下初始代码(20分)

//1141
#include <iostream>
#include <vector>
#include <cctype>
#include <algorithm>
#include <string>
using namespace std;
struct testee {
  string ID, scho;
  int sco, flag;
};
struct result {
  string school;
  int Ns, TWS;
};
bool cmp(result t1, result t2) {
  if (t1.TWS != t2.TWS) return t1.TWS > t2.TWS;
  else if (t1.Ns != t2.Ns) return t1.Ns < t2.Ns;
  else return t1.school < t2.school;
}
int main() {
  int n;
  cin >> n;
  vector<testee>t(n);
  vector<result>r;
  for (int i = 0; i < n; i++) {
    cin >> t[i].ID >> t[i].sco >> t[i].scho;
    for (int j = 0; j < t[i].scho.size(); j++)
      t[i].scho[j]=tolower(t[i].scho[j]);
    switch (t[i].ID[0]) {
    case 'B':t[i].sco /= 1.5; break;
    case 'T':t[i].sco *= 1.5; break;
    default:break;
    }
    t[i].flag = 0;
  }
  for (int i = 0; i < n; i++)
    if (!t[i].flag) {
      result rx;
      rx.school = t[i].scho;
      rx.Ns = 1;
      rx.TWS = t[i].sco;
      for (int j = i + 1; j < n; j++) {
        if (t[i].scho == t[j].scho) {
          rx.Ns++;
          rx.TWS += t[j].sco;
          t[j].flag = 1;
        }
      }
      r.push_back(rx);
    }
  sort(r.begin(), r.end(), cmp);
  cout << r.size() << endl;
  if (r.size()) {
    int i = 0;
    cout << i + 1 << " " << r[i].school << " " << r[i].TWS << " " << r[i].Ns << endl;
    for (int i = 1; i < r.size(); i++) {
      if (r[i].TWS == r[i - 1].TWS)
        cout << i << " " << r[i].school << " " << r[i].TWS << " " << r[i].Ns << endl;
      else cout << i + 1 << " " << r[i].school << " " << r[i].TWS << " " << r[i].Ns << endl;
    }
  }
  system("pause");
  return 0;
}

满分代码:

//1141
#include <iostream>
#include <vector>
#include <cctype>
#include <map>
#include <algorithm>
#include <string>
using namespace std;
struct result {
  string school;
  int Ns, TWS;
};
bool cmp(result t1, result t2) {
  if (t1.TWS != t2.TWS) return t1.TWS > t2.TWS;
  else if (t1.Ns != t2.Ns) return t1.Ns < t2.Ns;
  else return t1.school < t2.school;
}
int main() {
  int n;
  double sco;
  string ID, scho;
  cin >> n;
  map<string, int>count;
  map<string, double>sum;
  for (int i = 0; i < n; i++) {
    cin >> ID >> sco >> scho;
    for (int j = 0; j < scho.size(); j++)
      scho[j] = tolower(scho[j]);
    switch (ID[0]) {
    case 'B':sco /= 1.5; break;
    case 'T':sco *= 1.5; break;
    default:break;
    }
    count[scho]++;
    sum[scho] += sco;
  }
  vector<result>r;
  for (auto it = count.begin(); it != count.end(); it++)
    r.push_back(result{ it->first,  count[it->first],(int)sum[it->first] });
  sort(r.begin(), r.end(), cmp);
  cout << r.size() << endl;
  int rank = 0, pres = -1;
  for (int i = 0; i < r.size(); i++) {
    if (pres != r[i].TWS) rank = i + 1;
    pres = r[i].TWS;
    printf("%d ", rank);
    cout << r[i].school;
    printf(" %d %d\n", r[i].TWS, r[i].Ns);
  }
  system("pause");
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值