PAT Advanced 1141. PAT Ranking of Institutions (25)

问题描述:

1141. PAT Ranking of Institutions (25)

时间限制
500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where "ID" is a string of 6 characters with the first one representing the test level: "B" stands for the basic level, "A" the advanced level and "T" the top level; "Score" is an integer in [0, 100]; and "School" is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that "ID" is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where "Rank" is the rank (start from 1) of the institution; "School" is the institution code (all in lower case); "TWS" is the total weighted score which is defined to be the integer part of "ScoreB/1.5 + ScoreA + ScoreT*1.5", where "ScoreX" is the total score of the testees belong to this institution on level X; and "Ns" is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

纪念一下3月18日PAT满分×2

这一题的坑点在于1.5这个系数,一定要把每一个学校的T级·A级·B级分数和都计算出来后再算出等效的学校分数才能通过最后一个checkpoint

AC代码:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
#include<bits/stdc++.h>
using namespace std;
struct node
{
	string id;
	int num;
	int ag,bg,tg;
	bool operator<(const node& en) const
	{
		int g1=ag+bg*2/3+tg*3/2;
		int g2=en.ag+en.bg*2/3+en.tg*3/2;
		if(g1!=g2)
		return g1>g2;
		else if(num!=en.num)
		return num<en.num;
		else
		return id<en.id;
	}
} no;
int main()
{
//	freopen("data2.txt","r",stdin);
	ios::sync_with_stdio(false);
	unordered_map<string,int> m;
	vector<node> v;
	string s1,s2;
	int n,x,c1,c2;
	cin>>n;
	for(;n--;)
	{
		cin>>s1>>x>>s2;
		for(auto &i:s2)
		{
			if(i<='Z'&&i>='A')
			i=i-'A'+'a';
		}
		auto itm=m.find(s2);
		if(itm==m.end())
		{
			m[s2]=v.size();
			no.ag=0;
			no.tg=0;
			no.bg=0;
			no.id=s2;
			no.num=1;
			v.push_back(no);
		}
		else
		v[itm->second].num++;
		if(s1[0]=='B')
		v[m[s2]].bg+=x;
		else if(s1[0]=='A')
		v[m[s2]].ag+=x;
		else if(s1[0]=='T')
		v[m[s2]].tg+=x;
	}

	sort(v.begin(),v.end());

	cout<<v.size()<<endl;
	int r,g=-1;
	for(int i=0;i<v.size();i++)
	{
		int vg=v[i].ag+v[i].bg*2/3+v[i].tg*3/2;
		if(vg!=g)
		{
			r=i+1;
			g=vg;
		}
		cout<<r<<" "<<v[i].id<<" "<<vg<<" "<<v[i].num<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值