PAT A1015 Reversible Primes (20分)

PAT A1015 Reversible Primes 20分

原题

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<10​5​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

大体题意

给一个数和它是几进制,要求判断它是不是素数,如果是素数,要求判断在n进制基础上,它的水平翻转的数转换为十进制是不是素数

思路

涉及三点,进制转换、素数判断以及水平翻转

代码

#include <iostream>
#include <math.h>
using namespace std;

bool isprime(int n)
{
	if (n <= 1)
		return false;
	int sqr = (int)sqrt(1.0 * n);//因为sqrt的参数要求是浮点数,因此在n前面乘以1.0来使其成为浮点型
	for (int i = 2; i <= sqr; i++)
		if (n % i == 0)
			return false;
	return true;
}

int change(int n, int d)
{
	int a[10000];
	int i = 0;
	while (n != 0)
	{
		a[i++] = n % d;
		n = n / d;
	}

	int b[10000], j;
	for (j = 0; j < i; j++)
	{
		b[i - 1 - j] = a[j];
	}

	int sum = 0, l = 1;
	for (j = 0; j < i; j++)
	{
		sum += b[j] * l;
		l = l * d;
	}
	return sum;
}

int main()
{
	int n, d, k;
	cin >> n;
	while (n > 0)
	{
		cin >> d;
		if (isprime(n))
		{
			k = change(n, d);
			if (isprime(k))
				cout << "Yes" << endl;
			else
				cout << "No" << endl;
		}
		else
			cout << "No" << endl;
		cin >> n;
	}
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值