PAT1015 Reversible Primes (20 分)

1015 Reversible Primes (20 分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N ( &lt; 1 0 5 &lt;10^5 <105) and D ( 1 &lt; D ≤ 10 1&lt;D≤10 1<D10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No




解析

体会到了甲级和乙级的区别了。同样是水题,但是甲级会让你做更多的事情。也就是一道题考了几个点。




什么是Reversible Primes
这个数是素数的同时,将其转换为D进制的数,再反转,产出的数还是个素数。就是Reversible Primes
又考了素数,又考了进制转换 d=====( ̄▽ ̄*)b



Code:

#include<cstdio>
#include<cmath>
#include<string>
using namespace std;
bool isprime(int num) {
	if (num <= 1)
		return false;
	int SQRT = (int)sqrt(num*1.0);
	for (int i = 2; i <= SQRT; i++) 
		if (num % i == 0)
			return false;
	return true;
}
int change(int num, int D) {
	string result;   // 10`s to D`s
	do {
		result += num % D + '0';
		num /= D;
	} while (num != 0);
	return stoi(result, nullptr, D);
}
int main()
{
	int num, D;
	while (scanf("%d %d", &num, &D) == 2) {
		if (isprime(num) && isprime(change(num, D)))
			printf("Yes\n");
		else
			printf("No\n");
	}
}
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
bool isprime(unsigned num) {
	if (num <= 1)
		return false;
	for (int i = 2; i*i <= num; i++)
		if (num%i == 0)
			return false;
	return true;
}
unsigned rever(int num, int radix) {
	string result;
	do {
		result += num % radix+'0';
		num /= radix;
	} while (num);
	int sum = 0;
	for (auto x : result) {
		sum = sum * radix + x - '0';
	}
	return sum;
}
int main()
{
	int N, D;
	while ((cin >> N) && N >= 0) {
		cin >> D;
		if (isprime(N) && isprime(rever(N, D)))
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值