PAT A1024 Palindromic Number (25分)

该博客讨论了如何找到一个正整数的回文配对数,即通过与自身反转数相加,直至得到回文数。给出了一种在限制步骤内实现这一过程的算法,包括快速计算翻转数和进位的策略。并提供了示例输入和输出来说明其工作原理。
摘要由CSDN通过智能技术生成

1024 Palindromic Number 25分

原题

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​ ) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.
Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

大体题意

将数与自身的翻转数相加得到和,直到和是一个回文数。有限定的步数。

思路

重点在于如何快速地和翻转数相加
数:1 2 3 4 5
翻转数:5 4 3 2 1
由此可见翻转数在原本数中的位置为a[index-1-i]
其中index为数组的长度
因此将数和翻转数相加
b[i] = (a[i] + a[index-1-i] + carry) % 10;
carry = (a[i] + a[index-1-i] + carry) / 10;
carry为进位
由此就可以直接将数与翻转数相加,而无需得到翻转数再相加了

代码

#include <iostream>
using namespace std;

int index = 0;
//判断是不是回文
bool judge(int a[]) {
	for (int i = 0; i < index / 2; i++) {
		if (a[i] != a[index - i - 1]) return false;
	}
	return true;
}
//反向输出
void print(int a[], int step) {
	for (int i = index - 1; i >= 0; i--)
		printf("%d", a[i]);
	printf("\n%d", step);
}
//与翻转数相加
void addreverse(int a[]) {
	int b[100] = { 0 }, carry = 0;
	for (int i = 0; i < index; i++) {
		b[i] = (a[i] + a[index - i - 1] + carry) % 10;
		carry = (a[i] + a[index - i - 1] + carry) / 10;
	}
	if (carry != 0) b[index++] = carry;
	for (int i = 0; i < index; i++) {
		a[i] = b[i];
	}
}
int main() {
	int K, a[100] = { 0 }, i;
	long long N;
	cin >> N >> K;
	while (N) {
		a[index++] = N % 10;
		N /= 10;
	}
	for (i = 0; i <= K; i++) {
		if (judge(a) || i == K) break;
		addreverse(a);
	}
	print(a, i);
	return 0;
}

运行结果

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值