2016 多校联训 第三场Teacher Bo hdoj5762


Teacher Bo

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 795    Accepted Submission(s): 443


Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked  N  points in the map,the  i -th point is at  (Xi,Yi) .He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,ACorBD)  such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print "YES",else print "NO".
 

Input
First line, an integer  T . There are  T  test cases. (T50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates. (N,M105) .

Next N lines, the  i -th line shows the coordinate of the  i -th point. (Xi,Yi)(0Xi,YiM) .
 

Output
T  lines, each line is "YES" or "NO".
 

Sample Input
   
   
2 3 10 1 1 2 2 3 3 4 10 8 8 2 3 3 3 4 4
 

Sample Output
   
   
YES NO




这题数据很弱的样子,随便写写就过了。。。。
将点看成pair存入set,然后枚举每个点对,将亮点距离存起来,一旦再次出现该距离就退出循环直接打印yes
循环结束还未找打就输出no
下面贴代码:
#include <iostream>
#include <cstring>
#include <map>
#include <vector>
#include <algorithm>
#include <set>
#include <queue>
#include <cmath>
using namespace std;
const long long maxn=1e7;
int possible[maxn];
set<pair<int,int>> save;

int main(){
    int t,n,m;
    scanf("%d",&t);
    while(t--){
        memset(possible, 0, sizeof(possible));
        save.clear();
        pair<int,int> k;
        scanf("%d%d",&n,&m);
        while(n--){
            int a,b;
            scanf("%d%d",&a,&b);
            k = make_pair(a, b);
            save.insert(k);
        }
        /*for(set<pair<int,int>>::iterator it=save.begin();it!=save.end();it++){
            cout<<it->first<<" "<<it->second<<endl;
        }*/
        int god=0;
        for(set<pair<int,int>>::iterator i=save.begin();i!=save.end();i++){
            for(set<pair<int,int>>::iterator j=i;j!=save.end();j++){
                if(j==i){
                    continue;
                }
                unsigned dis=abs(i->first-j->first)+abs(i->second-j->second);
                if(possible[dis]==0){
                    possible[dis]=1;
                }else{
                    god=1;
                    goto here;
                }
            }
        }
    here:
        if(god){
            cout<<"YES"<<endl;
        }else{
            cout<<"NO"<<endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值