POJ 3349 Snowflake Snow Snowflakes

Problem Description
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
 

Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
 

Output
If all of the snowflakes are distinct, your program should print the message: No two snowflakes are alike. If there is a pair of possibly identical snow akes, your program should print the message: Twin snowflakes found.
 

Sample Input
  
  
2 1 2 3 4 5 6 4 3 2 1 6 5
 

Sample Output
  
  
Twin snowflakes found.


题目会告诉你n个雪花的各个边长,你的任务是判断给出的雪花中是否存在相同的雪花,按要求输出

现在的问题是,测试数据中给的n会非常大,所以不能每个两两比过去。先做一个筛选:将边长总和的雪花归类。

由于边长相加可能会非常大,数组开不到那么大。因此使用哈希表,每个雪花的边长相加取一个素数的模,这样可以将它们归类。

使用vector来储存哈希值相同的雪花,若它们的哈希值想等,那么它们极大几率下边长总和是一样的(利用取模这样的方法其实也可能会出现碰撞,即两个数不相等但取素数模的值相同,它们也会被分入同一组,但发生几率比较小)。

经过筛选后vector中存的size大于1的组就是可能为相同雪花的,这样再将它们进行比较


下面是代码:


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <map>
#include <stack>
#include <vector>
#include <cmath>
using namespace std;
const unsigned maxn=100005;
const int prime=99991;
struct snowflake{
    int snow[6];
};

vector<snowflake> hs[prime];

void Hash(snowflake a){
    int i;
    int sum=0;
    for(i=0;i<6;i++){
        sum += a.snow[i];
    }
    sum=sum%prime;
    hs[sum].push_back(a);
}
bool compare(snowflake a,snowflake b){
    for(int i=0;i<6;i++)
    {
        if(a.snow[0]==b.snow[i]&&a.snow[1]==b.snow[(i+1)%6]&&a.snow[2]==b.snow[(i+2)%6]&&
           a.snow[3]==b.snow[(i+3)%6]&&a.snow[4]==b.snow[(i+4)%6]&&a.snow[5]==b.snow[(i+5)%6])
            return true;
        if(a.snow[0]==b.snow[i]&&a.snow[1]==b.snow[(i+5)%6]&&a.snow[2]==b.snow[(i+4)%6]&&
           a.snow[3]==b.snow[(i+3)%6]&&a.snow[4]==b.snow[(i+2)%6]&&a.snow[5]==b.snow[(i+1)%6])
            return true;
    }
    return false;
}
int main(){
    int n,i;
    scanf("%d",&n);
    snowflake now;
    while(n--){
        for(i=0;i<6;i++){
            scanf("%d",&now.snow[i]);
        }
        Hash(now);
    }
    for(i=0;i<prime;i++){
        if(hs[i].size()>1){
            for(int j=0;j<hs[i].size();j++){
                for(int k=j+1;k<hs[i].size();k++){
                    if(compare(hs[i][j],hs[i][k])){
                        printf("Twin snowflakes found.");
                        return 0;
                    }
                }
            }
        }
    }
    printf("No two snowflakes are alike.");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值