poj 3349 Snowflake Snow Snowflakes

Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 38249 Accepted: 10017

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.


【分析】
一道数字哈希题目
暴力查询复杂度为O(6*n^2) 果断弃
其实说它是哈希也不太算
大概就是把一片雪花的所有参数的和哈希一下
然后逐个比较。。
这其实是个模拟啊喂


【代码】

//poj3349 Snowflake Snow Snowflakes
#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int ha=90001;
int snow[100002][6];
vector <int> hash[ha+1];
bool judge(int a,int b)
{
    int i,j,k;
    fo(i,0,5)   //枚举雪花起点 
    {
        int tot1=0,tot2=0;
        fo(j,0,5)
        {
          if(snow[a][j]==snow[b][(i+j)%6])
            tot1++;
          if(snow[a][j]==snow[b][(i-j+6)%6])
            tot2++;
        }
        if(tot1==6 || tot2==6) return true;
    }
    return false;
}
int main()
{
    int n,i,j,k;
    scanf("%d",&n);
    fo(i,1,n)
      fo(j,0,5)
        scanf("%d",&snow[i][j]);
    fo(i,1,n)
    {
        int key,sum=0;
        fo(j,0,5)
          sum+=snow[i][j];
        key=sum%ha;
        int len=hash[key].size()-1;
        fo(j,0,len)
          if(judge(hash[key][j],i))
          {
            printf("Twin snowflakes found.\n");
            return 0;
          }
        hash[key].push_back(i);
    }
    printf("No two snowflakes are alike.\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值