hdoj1541 stars 树状数组

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0


学长学姐们已经明确说明了这个是用树状数组来做,然而看完题意还是没有明白如何下手。。。。

然后去搜了题解,才知道原来题目的输入中,坐标x和y是排好序的。

那么,对于每一个拥有相同y坐标的点来说,在前输入的点都算做后输入点的level

对于两个在不同y坐标的点来说,前面输入的点中x值比当下值小就也算作自己的level

那么其实就很简单。。每次输入点对树状数组做更新就可以了

值得一提的是,在update函数中while的条件一定是x<=maxn,每个数字是不唯一的!!和之前做的马桶吸离散化不一样

下面是代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <map>
#include <set>
#include <vector>
using namespace std;
const int maxn=500005;
int n,c[maxn],num[maxn];

int lowbit(int x){
    return x&(-x);
}

void update(int x,int val){
    while(x<=maxn){
        c[x] += val;
        x += lowbit(x);
    }
}


int getsum(int x){
    int sum=0;
    while(x>0){
        sum += c[x];
        x -=lowbit(x);
    }
    return sum;
}
int main(){
    int i;
    while(~scanf("%d",&n)&&n){
        memset(c, 0, sizeof(c));
        memset(num, 0, sizeof(num));
        int x,y;
        for(i=1;i<=n;i++){
            scanf("%d%d",&x,&y);
            num[getsum(x+1)] += 1;
            update(x+1, 1);
        }
        for(i=0;i<n;i++){
            cout<<num[i]<<endl;
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值