hdu4004 The Frog's Games 二分查找+贪心 TWT Tokyo Olympic 1COMBO-2

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 6274 Accepted Submission(s): 3064


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output
For each case, output a integer standing for the frog's ability at least they should have.

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18

Sample Output
  
  
4 11

Source
小青蛙要比铁人(蛙?)三项,其中一项内容就是从河的这头跳到河的那头,河中间有落脚的石头,题目会给出每个石头离出发点多远,问小青蛙最低要具备跳多远的能力能够在m次之内跳到河对岸

之前自己写了个每个石头区间段尽量接近L/m的方法wrong anwser、、、、为啥呢。。。。

然后搜题解居然是二分查找答案,每次贪心地能跳多远跳多远

之前写过二分,这次再写一个熟悉熟悉。。。。

下面代码:


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=500010;
int save[maxn];
int L,n,m;
bool judge(int distance){
    int sum=0,i=0,j=0;
    if(distance*m<L){
        return false;
    }
    while(i<n+1){
        if(save[i+1]-save[i]>distance){
            return false;
        }
        j=i;
        while(save[j]-save[i]<=distance&&j<=n+2){
            j++;
        }
        //cout<<"distance:"<<distance<<" j: "<<j<<" "<<save[j]<<" i: "<<i<<" "<<save[i]<<endl;
        i=j-1;
        sum++;
    }
    //cout<<"sum: "<<sum<<" distance"<<distance<<endl;
    if(sum<=m){
        return true;
    }else{
        return false;
    }
}
/*
6 1 2
2
25 3 3
11 
2
18
*/
int main() {
    int i,j;
    while(~scanf("%d%d%d",&L,&n,&m)){
        for(int i=1;i<=n;i++){
            scanf("%d",&save[i]);
        }
        save[n+1]=L;
        save[0]=0;
        sort(save+1,save+2+n);
        /*cout<<"test"<<endl;
        for(i=1;i<=n+1;i++){
            cout<<save[i]<<" ";
        }
        cout<<endl;*/
        int left=0,right=L,middle;
        while(left<=right){
            middle=(left+right)/2;
            if(judge(middle)){
                right=middle-1;
            }else{
                left=middle+1;
            }
        }
        printf("%d\n",left);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值