hdu4004之二分查找

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 2554    Accepted Submission(s): 1315


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
  
4 11

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=500000+10;
int s[MAX];

int search(int left,int right,int v){//查找最右端<=v的数 
	while(left+1<right){//剩下两个元素的时候另外判段,如果left<right可能会无限循环 
		int mid=left+right>>1;
		if(s[mid]<=v)left=mid;
		else right=mid-1;
	}
	if(s[right]<=v)return right;
	return left;
}

int judge(int v,int n,int m){
	int num=0,left=0;
	while(left<n && ++num<=m)left=search(left,n,s[left]+v);//进行二分查找并且记录查找次数(即跳跃次数) 
	return num;
}

int main(){
	int L,n,m;
	while(scanf("%d%d%d",&L,&n,&m)!=EOF){
		for(int i=1;i<=n;++i)scanf("%d",s+i);
		sort(s,s+n+1);
		s[n+1]=L;
		int left=0,right=L,mid;
		while(left<right){//对于青蛙可能跳的距离进行二分 
			mid=left+right>>1;
			if(judge(mid,n+1,m)<=m)right=mid;//判断青蛙以跳跃距离mid最少跳几次到L 
			else left=mid+1;
		}
		cout<<right<<endl;
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值