hdu 5924/Mr. Frog’s Problem

Problem Description

One day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.

He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that A≤C≤B,A≤D≤B and AB+BA≤CD+DC
Input

first line contains only one integer T (T≤125), which indicates the number of test cases. Each test case contains two integers A and B (1≤A≤B≤1018).

Output

For each test case, first output one line "Case #x:", where x is the case number (starting from 1).

Then in a new line, print an integer s indicating the number of pairs you find.

In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.

Sample Input
2
10 10
9 27

Sample Output

Case #1:
1
10 10
Case #2:
2
9 27

27 9

你会发现只有A,B这两个点是ok的;

#include <iostream>
<span style="font-size:14px;">#include<stdio.h>
using namespace std;

int main()
{
    int T;
    cin>>T;
    for(int t=1;t<=T;t++)
    {
        __int64 a,b;
        scanf("%I64d %I64d",&a,&b);
        if(a==b)
        {
            printf("Case #%d:\n1\n%I64d %I64d\n",t,a,b);
        }else
        {
            printf("Case #%d:\n2\n%I64d %I64d\n%I64d %I64d\n",t,a,b,b,a);
        }
    }
    return 0;
}</span><span style="color:#ff0000;">
</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值