hdu5926 Mr. Frog’s Game 小模拟 国庆咸鱼

Mr. Frog’s Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 35 Accepted Submission(s): 28


Problem Description
One day, Mr. Frog is playing Link Game (Lian Lian Kan in Chinese).



In this game, if you can draw at most three horizontal or vertical head-and-tail-connected lines over the empty grids(the lines can be out of the whole board) to connect two non-empty grids with the same symbol or the two non-empty grids with the same symbol are adjacent, then you can change these two grids into empty and get several more seconds to continue the game.

Now, Mr. Frog starts a new game (that means there is no empty grid in the board). If there are no pair of grids that can be removed together,Mr. Frog will say ”I’m angry” and criticize you.

Mr. Frog is battle-scarred and has seen many things, so he can check the board in a very short time, maybe one second. As a Hong Kong Journalist, what you should do is to check the board more quickly than him, and then you can get out of the room before Mr. Frog being angry.

Input
The first line contains only one integer T ( T500 ), which indicates the number of test cases.

For each test case, the first line contains two integers n and m ( 1n,m30 ).

In the next n lines, each line contains m integers, j-th number in the i-th line means the symbol on the grid(the same number means the same symbol on the grid).

Output
For each test case, there should be one line in the output.

You should output “Case #x: y”,where x is the case number(starting from 1), and y is a string representing the answer of the question. If there are at least one pair of grids that can be removed together, the y is “Yes”(without quote), else y is “No”.

Sample Input
  
  
2 3 3 1 2 1 2 1 2 1 2 1 3 3 1 2 3 2 1 2 3 2 1

Sample Output
  
  
Case #1: Yes Case #2: No
Hint
first sample can be explained as below.

Source

很不科学的连连看。。。按照我的认知来说一般的连连看不是每个边界都可以连在一起吗???

然而这个是只有相邻的两个或者是处在同一条边上的相同数字才能连连消掉。。

反正降低难度了吧。。。一定有很多人按照自己玩连连看的习惯wa了吧

下面代码:


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
const int maxn=40;
int save[maxn][maxn];
bool judge[1000];
int main(){
	int t;
	scanf("%d",&t);
	int rnd=1;
	while(t--){
		int n,m,i,j;
		scanf("%d%d",&n,&m);
		bool flag=false;
		for(i=1;i<=n;i++){
			for(j=1;j<=m;j++){
				scanf("%d",&save[i][j]);
				if(i>1){
					if(save[i-1][j]==save[i][j]){
						flag=true;
					}
				}
				if(j>1){
					if(save[i][j-1]==save[i][j]){
						flag=true;
					}
				}
			}
		}
		if(!flag){
			memset(judge,false,sizeof(judge));
			for(i=1;i<=n;i++){
				if(!judge[save[i][1]]){
					judge[save[i][1]]=true;
				}else{
					flag=true;
					break;
				}
			}
			memset(judge,false,sizeof(judge));
			for(i=1;i<=n;i++){
				if(!judge[save[i][m]]){
					judge[save[i][m]]=true;
				}else{
					flag=true;
					break;
				}
			}
			memset(judge,false,sizeof(judge));
			for(i=1;i<=m;i++){
				if(!judge[save[1][i]]){
					judge[save[1][i]]=true;
				}else{
					flag=true;
					break;
				}
			}
			memset(judge,false,sizeof(judge));
			for(i=1;i<=m;i++){
				if(!judge[save[n][i]]){
					judge[save[n][i]]=true;
				}else{
					flag=true;
					break;
				}
			}
		}
		if(flag){
			printf("Case #%d: Yes\n",rnd);
		}else{
			printf("Case #%d: No\n",rnd);
		}
		rnd++;
	}
	
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值