hdu1242 Rescue bfs搜索

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27252    Accepted Submission(s): 9662


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source


写完后突然觉得会有很多个朋友。。。。因为题目用了friends。。。。那就很麻烦了。。。。因为存在别的朋友帮忙杀死卫兵其他朋友就不用耗时打卫兵了。。。

然而事实证明并没有那么复杂,只有一个朋友。。。1A。。。bfs裸题

angel的朋友很少

代码:

#include <cstdlib>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
using namespace std;
const int maxn=210;
const int INF=8000000;
char save[maxn][maxn];
int d[maxn][maxn];
int ex,ey;
int sx,sy;
int move_x[4]={0,0,1,-1};
int move_y[4]={1,-1,0,0};
int n,m;
int bfs(){
    queue<pair<int, int> > que;
    int i,j;
    for(i=1;i<=n;i++){
        for(j=1;j<=m;j++){
            d[i][j]=INF;
        }
    }
    que.push(make_pair(sx, sy));
    d[sx][sy]=0;
    while(que.size()){
        pair<int, int> q=que.front();
        que.pop();
        if(save[q.first][q.second]=='a'){
            return d[q.first][q.second];
        }
        for(i=0;i<4;i++){
            int dx=q.first+move_x[i];
            int dy=q.second+move_y[i];
            if(dx>=1&&dx<=n&&dy>=1&&dy<=m&&save[dx][dy]!='#'&&d[dx][dy]==INF){
                que.push(make_pair(dx, dy));
                if(save[dx][dy]!='x'){
                    d[dx][dy]=d[q.first][q.second]+1;
                }else{
                    d[dx][dy]=d[q.first][q.second]+2;
                }
            }
        }
    }
    return INF;
}
int main(){
    while(~scanf("%d%d",&n,&m)){
        int i,j;
        for(i=1;i<=n;i++){
            for(j=1;j<=m;j++){
                cin>>save[i][j];
                if(save[i][j]=='a'){
                    ex=i;
                    ey=j;
                }
                if(save[i][j]=='r'){
                    sx=i;
                    sy=j;
                }
            }
        }
        int result=bfs();
        if(result==INF){
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        }else{
            printf("%d\n",result);
        }
    }
    
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值