poj2965 The Pilots Brothers' refrigerator dfs+枚举

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24732 Accepted: 9535 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion

嗯。。。这是直接对着poj1753的ac代码改的,有种买一赠一的感觉。。。

也是枚举,也是16个操作之内就能解决,这题多了一个路径处理

呵呵。。。。路径处理什么的 。。。。。做就是了。。。

输出impossible这句话应该用不上了。。。

理解了1753的话这题也不难吧

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
#include <sstream>
#include <queue>
using namespace std;
const int maxn = 10;
bool board[maxn][maxn];
int dx[4] = {1,-1,0,0};
int dy[4] = {0,0,1,-1};
bool judge(){
    int i,j;
    for(i=1;i<=4;i++){
        for(j=1;j<=4;j++){
            if(!board[i][j]){
                return false;
            }
        }
    }
    return true;
}
int tot;
void flip(int r,int c){
    int i;
    for(i=1;i<=4;i++){
        board[i][c] = !board[i][c];
    }
    for(i=1;i<=4;i++){
        board[r][i] = !board[r][i];
    }
    board[r][c] = !board[r][c];
}
bool flag;
vector<pair<int, int> > way;
void dfs(int r,int c,int ans){
    if(ans == tot){
        if(judge()){
            flag = true;
        }
        return ;
    }
    if(r>4||flag){
        return;
    }
    
    flip(r, c);
    way.push_back(make_pair(r, c));
    if(c<4){
        dfs(r, c+1, ans+1);
    }else{
        dfs(r+1, 1, ans+1);
    }
    if(!flag){
        way.pop_back();
    }
    flip(r, c);
    
    if(c<4){
        dfs(r, c+1, ans);
    }else{
        dfs(r+1, 1, ans);
    }
    
    return;
}
int main(){
    int i,j;
    char unit;
    for(i=1;i<=4;i++){
        for(j=1;j<=4;j++){
            cin>>unit;
            if(unit=='-'){
                board[i][j] = true;
            }else{
                board[i][j] = false;
            }
        }
    }
    flag = false;
    for(i=0;i<=16;i++){
        tot = i;
        way.clear();
        dfs(1, 1, 0);
        if(flag){
            break;
        }
    }
    if(!flag){
        cout<<"Impossible\n";
    }else{
        cout<<i<<endl;
        for(i=0;i<way.size();i++){
            cout<<way[i].first<<" "<<way[i].second<<endl;
        }
    }
    
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值