POJ2240 Arbitrage BellmaFord判最短路回路

Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21764 Accepted: 9271

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

这和1860简直就是一摸一样啊。。。然后我就改改改。。。。

并没有理解精髓,怎么办呢。。。。飞机还晚点好想吃汉堡可恶。。。。。周围的味道好香啊。。。

武道之神助我好好拿下这八个学分吧。。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;
const int maxn = 35;
int n,m,p;
double INF = 999999999;
double save[maxn][maxn];
map<string,int> change;
double dis[maxn];
pair<int,int> edge[maxn*maxn];
void init(){
    int i;
    for(i=1;i<=n;i++){
        dis[i] = 0.0f;
    }
}
void relax(int u,int v){
    if(dis[v]<dis[u]*save[u][v]){
        dis[v] = dis[u]*save[u][v];
    }
}
bool BellmanFord(){
    int i,j;
    for(i=1;i<=n-1;i++){
        for(j=1;j<=p;j++){
            relax(edge[j].first,edge[j].second);
        }
    }
    for(i=1;i<=p;i++){
        int u = edge[i].first;
        int v = edge[i].second;
        if(dis[v]<dis[u]*save[u][v]){
            return true;
        }
    }
    return false;
}
int main(){
    int rnd=1,i,j;
    string a,b;
    while(~scanf("%d",&n)&&n){
        change.clear();
        init();
        int num = 0;
        double rate;
        for(i=1;i<=n;i++){
            cin>>a;
            change[a]  = ++num;
            if(i==1){
                dis[change[a]] = 10.0;
            }
        }
        scanf("%d",&m);
        p = 0;
        int from,to;
        for(i=1;i<=m;i++){
            cin>>a>>rate>>b;
            from = change[a];
            to = change[b];
            save[from][to] = rate;
            edge[++p] = make_pair(from, to);
        }
        printf("Case %d: ",rnd++);
        if(BellmanFord()){
            printf("Yes\n");
        }else{
            printf("No\n");
        }
    }
    
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值