POJ - 1703 Find them, Catch them (并查集)

点击打开题目链接

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

今天下午教主突然来了一场手速题,本猪真是有苦说不出啊。清明三天的集训结束了,收获了不少,无论从选题,团队的配合还是算法上都学到了很多,(T~T其实本猪想说提升最大最多的还是心理承受能力),明天又正式上课了,突然感觉好幸福... ...

这是不久前集训的时候一场比赛的题,当时16级能A出来的寥寥无几,当时我还在用数组做呢,现在回看这个题,觉得毫无压力。感叹我们真的进步了许多,这种进步在平时是看不出来的,只有与之前对比才会显现出来,所以,本猪相信,努力必然会进步!(=。=!来,喝了这碗掺杂着DDV的毒鸡汤养养胃)

题目大意:有两个帮派,给你一些信息关于两个人是不是在不同帮派里,然后让你判断出任意两人是不是同一帮派的。创建一个2*N的并查集即可。一开始无法输入数字,发现没用getchar吃回车。RE了一次,数组开小了,应该是两倍

附上AC代码:

#include<bits/stdc++.h>

using namespace std;
const int maxn=1e5+5;
int par[maxn*2];
int T;
int n,m;
int x,y;
char c;

void init(int a)
{
    for(int i=0;i<=2*a;i++)
        par[i]=i;
}
int find(int a)
{
    if(a==par[a])
        return a;
    return par[a]=find(par[a]);
}
void unite(int a,int b)
{
    a=find(a);
    b=find(b);
    if(a==b) return;
    par[a]=b;
}
bool same(int a,int b)
{
    return find(a)==find(b);
}

int main()
{
    scanf("%d",&T);
    getchar();
    while(T--)
    {
        scanf("%d%d",&n,&m);
        getchar();
        init(n);
        for(int i=0;i<m;i++)
        {
            scanf("%c%d%d",&c,&x,&y);
            getchar();
            if(c=='A')
            {
                if(same(x,y+n))
                    printf("In different gangs.\n");
                else if(same(x,y))
                    printf("In the same gang.\n");
                else
                    printf("Not sure yet.\n");
            }
            else if(c=='D')
            {
                unite(x,y+n);
                unite(x+n,y);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值