POJ - 2386 Lake Counting(DFS连通块水题)

点击打开题目链接

Lake Counting
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 33863Accepted: 16851

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

本题是DFS里最经典也是最基础的连通块问题,每次dfs都将它所临近的W用'.'代替,直到图中不存在W为止,这样dfs的次数就为连通块的个数

注意这一题和之前写的一题状态转移不同(上一题只有上下左右四种状态,这个题多了四个对角的状态),所以dfs函数内部有八个方向。

附上AC代码:

#include<iostream>

using namespace std;
const int maxn=100;
int dx[]={0,1,0,-1},dy[]={1,0,-1,0};
int vis[maxn][maxn];
char c[maxn][maxn];
 int po=0;
 int n,m;

void  dfs(int x,int y)
{
    c[x][y]='.';
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
        {
            int nx=dx[i]+x;
            int ny=dy[j]+y;
            if(nx<0||nx>=n||ny<0||ny>=m||c[nx][ny]=='.')
                continue;
            if(c[nx][ny]=='W')
            {
                dfs(nx,ny);
            }
        }
}

int main()
{
    cin>>n>>m;
        for(int i=0;i<n;i++)
            cin>>c[i];
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                if(c[i][j]=='W')
                {
                    dfs(i,j);
                    po++;
                }
            }
            cout<<po<<endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值