HDU - 5867 Water problem(水+打表)

点击打开题目链接

Water problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 744    Accepted Submission(s): 348

Problem Description

If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?

Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of "and" when writing out numbers is in compliance with British usage.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.

For each test case: There is one positive integer not greater one thousand.

Output

For each case, print the number of letters would be used.

Sample Input

 
 
3 1 2 3

Sample Output

 
 
3 6 11

Author

BUPT

Source

Recommend

wange2014
Statistic  |  Submit  |  Discuss  |  Note
题目大意:输入1到1000中的一个数N,输出从1到N所有数英文字母个数之和。
思路:打表之后循环一遍求和。(QAQ 无奈,英语学的不好,不知道英文怎么拼写)
附上AC代码:(用万能头文件是过不了的,头文件还需要自己补)
#include<bits/stdc++.h>

const int maxn = 1000+5;
using namespace std;
int vis[maxn];

void init()
{
    vis[1] = 3;
    vis[2] = 3;
    vis[3] = 5;
    vis[4] = 4;
    vis[5] = 4;
    vis[6] = 3;
    vis[7] = 5;
    vis[8] = 5;
    vis[9] = 4;
    vis[10] = 3;
    vis[11] = 6;
    vis[12] = 6;
    vis[13] = 8;
    vis[14] = 8;
    vis[15] = 7;
    vis[16] = 7;
    vis[17] = 9;
    vis[18] = 8;
    vis[19] = 8;
    vis[20] = 6;
    vis[30] = 6;
    vis[40] = 5;
    vis[50] = 5;
    vis[60] = 5;
    vis[70] = 7;
    vis[80] = 6;
    vis[90] = 6;
    vis[100] = 10;
    vis[200] = 10;
    vis[300] = 12;
    vis[400] = 11;
    vis[500] = 11;
    vis[600] = 10;
    vis[700] = 12;
    vis[800] = 12;
    vis[900] = 11;
    vis[1000] = 11;
    for(int i=21; i<=91; i=i+10)
        for(int j=0; j<9; j++)
        {
            vis[i+j] = vis[i-1]+vis[j+1];
            //if(i==31 && j==2)
                //cout << vis[i-1] << " " << vis[j+1];
        }

    for(int i=101; i<=901; i=i+100)
      for(int j=0; j<99; j++)
            vis[i+j] = vis[i-1]+vis[j+1] + 3;
}
int main()
{
    init();
    int t;
    int x;
    while(~scanf("%d",&t) && t)
    {
        for(int i=0; i<t; i++)
            {
                cin >> x;
               int sum = 0;
               for(int i=1; i<=x; i++)
                 sum+=vis[i];
                 cout << sum << endl;
            }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值