HDU - 1150 Machine Schedule(最小点覆盖)

55 篇文章 0 订阅
6 篇文章 0 订阅

点击打开题目链接

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9000    Accepted Submission(s): 4518

Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

 
 
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0

Sample Output

 
 
3

Source

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:   1151  1281  1507  1528  1054 

Statistic | Submit | Discuss | Note

题目大意:n个任务都可以在A机器上也可以在B机器上操作,每个机器有多种操作模式,当改变操作方式时机器会重启一次。对于给出的n个任务,计算出最小的机器重启数。

思路:每个任务建立x->y的边,求最少得点可以连接所有边,即求最小点覆盖。最小点覆盖=最大二分匹配数。

匈牙利算法

附上AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;
const int maxn=100+5;
int G[maxn][maxn];
int used[maxn];
int result[maxn];
int u,v,T;
int t,x,y;
int cnt;
//从左边开始找增广路
int find(int x)
{
    for(int i=0;i<v;i++)
    {
        if(G[x][i]==1&&!used[i])
        {
            used[i]=1;
            if(result[i]==-1||find(result[i]))
            {
                result[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    ios::sync_with_stdio(false);
    
    while(cin>>u,u)
    {
        cnt=0;
        memset(result,-1,sizeof(result));
        memset(G,0,sizeof(G));
        cin>>v>>T;
        
        for(int i=0;i<T;i++)
        {
            cin>>t>>x>>y;
            if(x>0&&y>0)//初始态为0,所以0边不添加
            G[x][y]=1;
        }
        
        for(int i=0;i<u;i++)
        {
            memset(used,0,sizeof(used));//每次都要初始化标记
            if(find(i))cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值