HDU - 4430 Yukari‘s Birthday(二分)

点击打开题目链接

Yukari's Birthday

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6368    Accepted Submission(s): 1539

Problem Description

Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place ki candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.

Input

There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 1012.

Output

For each test case, output r and k.

Sample Input

 
 
18 111 1111

Sample Output

 
 
1 17 2 10 3 10

Source

Recommend

zhuyuanchen520

Statistic | Submit | Discuss | Note

题目大意:

给出蜡烛数n,打算摆成同心圆,要求每一层i的蜡烛数为k^i.要求给出使得r*k最小的r和k。其中r为同心圆的个数,k为第一层的蜡烛数。最中心选择可以插一个蜡烛或者不插。

思路:

r最多40,而k最多1000000。所以可以枚举r,再对k二分。注意讨论中心有无蜡烛两种情况

附上AC代码:

#include<iostream>

using namespace std;
typedef long long ll;
const int INF=0x7f7f7f;
ll ans,n,k;
int r;
//二分枚举k
int binary(int r,ll n){
    ll ln=2,rn=1000000,sum,tmp;
    while(ln<=rn){
        ll mid=(ln+rn)>>1;
        sum=1,tmp=1;
        for(int i=1;i<=r;i++){
            tmp*=mid;
            sum+=tmp;
            if(sum>n)break;
        }
        if(sum==n)return mid;
        else if(sum>n){
            rn=mid-1;
        }
        else ln=mid+1;
    }
    return -1;
}

int main(){
    ios::sync_with_stdio(false);
    while(cin>>n){
        ans=INF;
        r=1,k=n-1;
        //遍历r
        for(int i=1;i<=40;i++){
            ll tmp=binary(i,n);
            if(tmp!=-1){
                if(i*tmp<ans){
                    ans=i*tmp;
                    r=i,k=tmp;
                }
            }
            tmp=binary(i,n+1);
            if(tmp!=-1){
                if(i*tmp<ans){
                    ans=i*tmp;
                    r=i,k=tmp;
                }
            }
        }
        cout<<r<<' '<<k<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值