HDU - 1505 City Game(最大子矩阵)

55 篇文章 0 订阅
11 篇文章 0 订阅

点击打开题目链接

City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7541    Accepted Submission(s): 3262

Problem Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

 
 
2 5 6 R F F F F F F F F F F F R R R F F F F F F F F F F F F F F F 5 5 R R R R R R R R R R R R R R R R R R R R R R R R R

Sample Output

 
 
45 0

Source

Recommend

zl   |   We have carefully selected several similar problems for you:   1069  1203  1176  1087  2870 

Statistic | Submit | Discuss | Note

题目大意:

给出M*N的矩阵,R为不可使用,F为可使用。求最大的F连通的矩形面积*3(矩形内全为F);

思路:

刚做完1506的最大子矩阵题,这个题可以说是1506的升级版。1506那个题是底轴做底,并且给出了高的长度。

同样,这个题可以将二位数组转化成每一行为底,纵向H的个数为高。

首先,二维数组h[][]求每个位置对应的高。然后在1506的基础上外围加一层for循环对于行数的遍历。

HDU - 1506 题解

附上AC代码:

#include<iostream>
#include<cstring>

using namespace std;
const int maxn = 1000 + 5;
typedef long long ll;
char c[maxn][maxn];
int l[maxn], r[maxn], h[maxn][maxn];
int T;
int m, n, t;
ll ans;

int main() {
    ios :: sync_with_stdio(false);
    cin >> T;
    while(T--){
        cin >> m >> n;
        for(int i = 0; i < m; i++){
            for(int j = 0; j < n; j++){
                cin >> c[i][j];
            }
        }
        //求h[][]数组
        memset(h, 0, sizeof(h) );
        for(int i = 0; i < m; i++){
            for(int j = 0; j < n; j++){
                if(c[i][j] == 'R'){
                    h[i][j] = 0;
                    continue;
                }
                for(int k = i; k < m; k++){
                    if(c[k][j] == 'R')break;
                    else h[i][j]++;
                }
            }
        }
        //遍历求ans
        ans = 0;
        for(int i = 0; i < m; i++){//比1506多了行的遍历
            memset(l, 0, sizeof(l) );
            memset(r, 0, sizeof(r) );
            l[0] = 0;
            r[n - 1] = n - 1;
            for(int j = 1; j < n; j++){
                t = j;
                while(t > 0 && h[i][t - 1] >= h[i][j])
                    t = l[t - 1];
                l[j] = t;
            }
            for(int j = n - 2; j >= 0; j--){
                t = j;
                while(t < n - 1 && h[i][t + 1] >= h[i][j])
                    t = r[t + 1];
                r[j] = t;
            }
            for(int j = 0; j < n; j++){
                if((r[j] - l[j] + 1) * h[i][j] > ans){
                    ans = (r[j] - l[j] + 1) * h[i][j];
                }
            }
        }
        cout << ans * 3 << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值