HDU 6441 - Find Integer(勾股数)

 

Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 41    Accepted Submission(s): 15
Special Judge

 

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

 

 

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

 

 

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

 

 

Sample Input

 

1

2 3

 

 

Sample Output

 

4 5

 

 

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

 

勾股数规律:

首先是奇数组口诀:平方后拆成连续两个数。

其次是偶数组口诀:平方的一半再拆成差2的两个数

 

#pragma GCC optimize(2)
#include<bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define line cout << "------------" << endl

typedef long long ll;
const int maxn = 1e5 + 10;
const int MAXN = 1e6 + 10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1010;

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		ll a, n;
		scanf("%lld%lld", &n, &a);
		if(n > 2 || n == 0) printf("-1 -1\n");
		else{
			ll b, c, s;
			if(n == 1) printf("1 %lld\n", a+1);
			else if(n == 2){
				if(a%2 == 1){
					b = a * a /2;
					c = b + 1;
				}
				else{
					s = a * a / 2;
					b = s / 2 - 1;
					c = s / 2 + 1;
				}
				printf("%lld %lld\n", b, c);
			}
		}
	}
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值