Brackets

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7728 Accepted: 4098

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
 

Sample Output

6
6
4
0
6

/*
分类:区间DP
思路:先求出需要完成括号匹配需要添加的括号
如果为0,说明已经匹配的为len
否则为len-已经匹配的数目 
*/


#include<stdio.h>
#include<algorithm>
#include<string.h>


using namespace std;


char ss[102];


int main(){

while(scanf("%s",ss)&&strcmp(ss,"end")!=0){

int len=strlen(ss);
int dp[102][102]={0};

for(int i=0;i<len;i++)
dp[i][i]=1;

for(int i=1;i<len;i++)//区间长度 
{
for(int j=0;j<len-i;j++){//开始位置 

int k=j+i;//结束位置 
dp[j][k]=0x3f3f3f; 
if((ss[j]=='('&&ss[k]==')')||(ss[j]=='['&&ss[k]==']'))
dp[j][k]=min(dp[j][k],dp[j+1][k-1]);

for(int t=j;t<k;t++){
dp[j][k]=min(dp[j][k],dp[j][t]+dp[t+1][k]);
}
}
} 
if(dp[0][len-1]==0)
printf("%d\n",len);
else 
printf("%d\n",len-dp[0][len-1]);

} 
}

//思路二:直接求匹配的数目
#include<stdio.h>
#include<algorithm>
#include<string.h>

using namespace std;

char ss[102];
bool  check(char c,char d){
	if(c=='('&&d==')')
	return true;
	if(c=='['&&d==']')
	return true;
	else
	return false;
	
} 
int main(){
	
	while(scanf("%s",ss)&&strcmp(ss,"end")!=0){
		
		int len=strlen(ss);
		int dp[102][102]={0};
		
		for(int i=0;i<len;i++){
				dp[i][i]=0;//初始化为0,匹配的数目为0 
				if(check(ss[i],ss[i+1]))
				dp[i][i+1]=2;// 已经匹配的加2 
				else 
				dp[i][i+1]=0;//初始化为0,匹配的数目为0 
		}
	
				
		for(int i=1;i<len;i++)//区间长度 
		{
			for(int j=0;j<len-i;j++){//开始位置 
				
				int k=j+i;//结束位置 
				dp[j][k]=0; //初始化为0,匹配的数目为0 
				if((ss[j]=='('&&ss[k]==')')||(ss[j]=='['&&ss[k]==']'))
				dp[j][k]=max(dp[j][k],dp[j+1][k-1]+2);
				
				for(int t=j;t<k;t++){
					dp[j][k]=max(dp[j][k],dp[j][t]+dp[t+1][k]);
				}
			}
		}	
	
	
		printf("%d\n",dp[0][len-1]);
			
	}	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值