Brackets! Brackets!

Brackets! Brackets!
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 698(239 users)Total Accepted: 272(210 users)Rating: Special Judge: No
Description

There are six kinds of brackets: ‘(‘, ‘)’, ‘[‘, ‘]’, ‘{’, ‘}’. dccmx’s girl friend is now learning java programming language, and got mad with brackets! Now give you a string of brackets. Is it valid? For example: “(([{}]))” is valid, but “([)]” is not.

Input

First line contains an integer T (T<=10): the number of test case.

Next T lines, each contains a string: the input expression consists of brackets.

The length of a string is between 1 and 100.

Output

For each test case, output “Valid” in one line if the expression is valid, or “Invalid” if not.

Sample Input
2
{{[[(())]]}}
({[}])
Sample Output
Valid
Invalid
 
注意()()这种情况合法。()())这种情况会令flag==0;()(这种情况会令栈为空。
 
如果出现一个右括号,那么在栈非空的情况下,如果合法必然栈顶元素和这个右括号相匹配。那么在这两个条件都不能满足的条件下flag==0;
#include<iostream>
#include<string.h>
#include<stack>
using namespace std;
int main()
{
	int T;char gq[101];
	cin>>T;
	while(T--)
	{
		stack<char>ls;
		scanf("%s",&gq);
		int flag=1;
		for(int i=0;i<strlen(gq);i++)
		{
			if(gq[i]=='('||gq[i]=='{'||gq[i]=='[')
			ls.push(gq[i]);
		else
		    {
			if(gq[i]==')')
			{
				if(!ls.empty()&&ls.top()=='(')
				{
					ls.pop();
				}
				else
				{
					flag=0;
					break;
				}
			}
			else if(gq[i]=='}')
			{
				if(!ls.empty()&&ls.top()=='{')

				{
					ls.pop();
				}
				else
				{
					flag=0;
					break;
				}
			}
			else if(gq[i]==']')
			{
				if(!ls.empty()&&ls.top()=='[')

				{
					ls.pop();
				}
				else 
				{
					flag=0;
					break;
				}
			}
		  }
		}
		if(!ls.empty()||flag==0)
			cout<<"Invalid"<<endl;
		else
			cout<<"Valid"<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值