Shaolin

Shaolin

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3205    Accepted Submission(s): 1360


Problem Description
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
 

Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.
 

Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.
 

Sample Input
  
  
3 2 1 3 3 4 2 0
 

Sample Output
  
  
2 1 3 2 4 2
 

Source

题意大意:很多人想进少林寺,少林寺最开始只有一个和尚,每个人有有一个武力值,若这个人想进少林,必须和比他先进去的人比武并且武力值最接近他的比武,如果有相同的则选择武力值比他小的,问当他进去的时候要和哪个和尚比武

lower_bound()总结:

当参数 key 没有在容器 key的范围内:
1. 小于容器key uper_bound, lower_bound 都将返回 begin.
2. 大于容器key uper_bound, lower_bound 都将返回 end(注意end已经超界了)
当参数key 在容器key 范围内:
1. 参数 key == 容器key. lower_bound 将返回当前key 的iterator, uper_bound 将返回下一个元素的iterator.
2. 参数 key 不等于容器key,且在范围内, lower_bound将返回比参数key 大的且相邻的容器key的iterator
3 如果 Key等于 begin 或等于 end,将返回begin 或end


#include <iostream>  
#include <algorithm>  
#include <cstdio>  
#include <map>  
#include <algorithm>  
using namespace std;  
  
int main()  
{  
  
    int n;  
    while(scanf("%d",&n)!= EOF && n)  
    {  
        map<int,int> mp;  
        mp[1e9] = 1;  
  
        while(n--)  
        {  
            int k,g;  
            scanf("%d%d",&k,&g);  
            map<int,int>::iterator i = mp.lower_bound(g);  
            if(i == mp.begin())  printf("%d %d\n",k,i->second);  
            else  
            {  
                map<int,int>::iterator a = i, b= --i;  
                if((a->first - g) >= (g -b->first) )  
                {  
                    printf("%d %d\n",k,b->second);  
                }  
                else printf("%d %d\n",k,a->second);  
            }  
            mp[g] = k;  
  
        }  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
优化下列代码 if arg == 103 then if GetMenPai(sceneId, selfId) ~= 9 then x990010_MsgBox( sceneId, selfId, targetId, "你已是别的门派的高徒了,我们不收你。" ) return end LuaFnJoinMenpai(sceneId, selfId, targetId, MP_SHAOLIN) LuaFnSetXinFaLevel(sceneId,selfId,1,30) LuaFnSetXinFaLevel(sceneId,selfId,2,30) LuaFnSetXinFaLevel(sceneId,selfId,3,30) LuaFnSetXinFaLevel(sceneId,selfId,4,30) LuaFnSetXinFaLevel(sceneId,selfId,5,30) LuaFnSetXinFaLevel(sceneId,selfId,6,30) --LuaFnSetXinFaLevel(sceneId,selfId,55,60) --LuaFnSetXinFaLevel(sceneId,selfId,72,60) LuaFnSendSpecificImpactToUnit(sceneId, selfId, selfId, selfId, 148, 0) local nam = LuaFnGetName( sceneId, selfId ) BroadMsgByChatPipe( sceneId, selfId, "#cFF0000[门派公告]:#c66ccff["..nam.."]#P已经加入了"..x990010_g_mpInfo[arg-101][1].."!", 4 ) CallScriptFunction( 999994, "ActionSkill",sceneId, selfId, -1 ) x990010_ooo( sceneId, selfId) end if arg == 104 then if GetMenPai(sceneId, selfId) ~= 9 then x990010_MsgBox( sceneId, selfId, targetId, "你已是别的门派的高徒了,我们不收你。" ) return end LuaFnJoinMenpai(sceneId, selfId, targetId, MP_TIANSHAN) LuaFnSetXinFaLevel(sceneId,selfId,43,30) LuaFnSetXinFaLevel(sceneId,selfId,44,30) LuaFnSetXinFaLevel(sceneId,selfId,45,30) LuaFnSetXinFaLevel(sceneId,selfId,46,30) LuaFnSetXinFaLevel(sceneId,selfId,47,30) LuaFnSetXinFaLevel(sceneId,selfId,48,30) --LuaFnSetXinFaLevel(sceneId,selfId,62,60) --LuaFnSetXinFaLevel(sceneId,selfId,79,60) LuaFnSendSpecificImpactToUnit(sceneId, selfId, selfId, selfId, 148, 0) local nam = LuaFnGetName( sceneId, selfId ) BroadMsgByChatPipe( sceneId, selfId, "#cFF0000[门派公告]:#c66ccff["..nam.."]#P已经加入了"..x990010_g_mpInfo[arg-101][1].."!", 4 ) CallScriptFunction( 999994, "ActionSkill",sceneId, selfId, -1 ) x990010_ooo( sceneId, selfId) end
最新发布
05-19

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值