hdu 4585 2013杭州邀请赛 Shaolin

Shaolin

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account. When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his. The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
 

Input
  
  
There are several test cases. In each test case: The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000) The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first. The input ends with n = 0.
 

Output
  
  
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.
 

Sample Input
  
  
3 2 1 3 3 4 2 0
 

Sample Output
  
  
2 1 3 2 4 2
用了个set就过了,
#include <iostream>
#include <stdio.h>
#include <set>
#include <string.h>
using namespace std;
struct node
{
  int id,val;
  bool operator < (node b)const
  {
      if(val!=b.val)
      return val<b.val;
      return id<b.id;
  }
};
set<node> q;
set<node >::iterator p,pp;
int main()
{
    int n,id,val,i,maxid,minid,maxval,minval;
    node temp;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        break;
        q.clear();
        temp.id=1;temp.val=1000000000;
        q.insert(temp);
        for(i=2;i<=n+1;i++)
        {
            scanf("%d%d",&temp.id,&temp.val);
            q.insert(temp);
            //p=q.begin();
            p=q.find(temp);
            if(p==q.begin())
            {
                p++;
                printf("%d %d\n",temp.id,p->id);
                continue;
            }

            p++;
            if(p==q.end())
            {
                p--;p--;
               printf("%d %d\n",temp.id,p->id);
               continue;
            }
            p--;
            p--;
            minval=p->val;
            minid=p->id;
            ++p,++p;
            maxval=p->val;
            maxid=p->id;
            if(maxval-temp.val<temp.val-minval)
            {
                printf("%d %d\n",temp.id,maxid);
            }
            else
                printf("%d %d\n",temp.id,minid);


        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值