hdoj4585 Shaolin (set+map)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=4585

Shaolin

Problem Description
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
 
Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.
 
Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.
 
Sample Input
  
  
3 2 1 3 3 4 2 0
 
Sample Output
  
  
2 1 3 2 4 2
    题意:有n+1个和尚,按进寺庙的先后标号为1~ (n+1),每个和尚都有一个唯一的战斗值(也就是不会和其它的和尚战斗值相同,这一点很重要),第一个和尚的战斗值为1000000000,再按和尚标号的升序来输入另外n个和尚的标号和战斗值。开始只有一号在寺庙,其它的n个和尚进寺庙的时候都要与已经在寺庙的和尚打架,他会找与自己战斗力最接近的和尚作战,若有多个人符合条件,则找标号最小的人。然后每输入 一个和尚的值,就要输出自己的标号和与其对战的人的标号。

思路:

由题意的战斗值的唯一性,可以set 存战斗值,用map把战斗值映射成标号;通过set中战斗值比较大小,再用map输出对应的标号。

#include<map>
#include<set>
#include<cstdio>
#include<cstring>
#include <iostream>
using namespace std;
int main()
{
    int  n,a,b;
    while(scanf("%d",&n)&&n)
    {
        set<int > grade;
        map<int ,int > id;
        grade.insert(1000000000);
        id[1000000000]=1;
        while(n--)
        {
            scanf("%d%d",&a,&b);
            printf("%d ",a);
            set<int >::iterator g=grade.upper_bound(b);
            if(g!=grade.begin())
            {
                int x=*g;
                g--;
                int y=*g;
               if(b-y<=x-b)printf("%d\n",id[y]);
               else printf("%d\n",id[x]);

            }
            else  printf("%d\n",id[*g]);
            grade.insert(b);
            id[b]=a;
        }
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值