HDU3496:Watch The Movie

点击打开题目链接

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 3969    Accepted Submission(s): 1259


Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy. 
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 

Sample Input
      
      
1 3 2 10 11 100 1 2 9 1
 

Sample Output
      
      
3
 

Source
 

Recommend
zhouzeyong
 


=====================================题目大意=====================================


帮助朵朵的叔叔从朵朵最喜欢的N张卡通片中选择M张总时间不超过L的卡通片送给朵朵使得它们对于朵朵的价值之和最大。


=====================================算法分析=====================================


简单的01背包问题。

状态转移方程为F[i][j][k]=MAX(F[i-1][j][k],F[i-1][j-1][k-t[i]]+v[i]),i代表前i件物品,j代表选取j件物品,k代表

背包大小为k,答案即F[N][M][L]。

注意这里的j是选取正好j件的物品而不是选取不多于j件的物品(因为题目求的是选取正好M件物品)。


=======================================代码=======================================




#include<stdio.h>
#include<string.h>

#define MAX(A,B) ((A)>(B)?(A):(B))

int T,N,M,L,F[105][1005];

int main()
{
    while(scanf("%d",&T)==1) while(T--)
    {
        memset(F,-1,sizeof(F));
        memset(F[0],0,sizeof(F[0]));   
        scanf("%d%d%d",&N,&M,&L);
        for(int i=0;i<N;++i)
        { 
			int t,v;
            scanf("%d%d",&t,&v);
            for(int j=M;j>=1;--j)
            {
                for(int k=L;k>=t;--k) if(F[j-1][k-t]!=-1)     
                {
                    F[j][k]=MAX(F[j][k],F[j-1][k-t]+v);
                }
            }
        }
        printf("%d\n",F[M][L]==-1?0:F[M][L]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值