HDU 3496 Watch The Movie(二维背包)

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 7105    Accepted Submission(s): 2244


Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy.
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 

Sample Input
  
  
1 3 2 10 11 100 1 2 9 1
 

Sample Output
  
  
3
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   2955  2602  2159  2844  3033 
一个二维背包,前两天一直写的都是一维的,并且初始化很重要, 当背包要求被装满时,除dp[0]初始化为0,其余初始化为负无穷,当背包要求装的价值最大时,全部初始化为0;此题由于可能出现负数。所以dp[0]为0,其余为负无穷


 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
int dp[110][1100],t[110],v[110];
int main()
{
	int n,m,i,j,l,p,k;
	scanf("%d",&p);
	while(p--)
	{
		scanf("%d%d%d",&n,&m,&l);
		for(i=0;i<n;i++)
		scanf("%d%d",&t[i],&v[i]);
		for(i=0;i<=m;i++)
		for(j=0;j<=l;j++)
		{
			if(i==0)
			dp[i][j]=0;//注意 
			else
			dp[i][j]=-INF;//有可能出现负数 
		 } 
		for(i=0;i<n;i++)
		for(j=m;j>=1;j--)
		for(k=l;k>=t[i];k--)
		{
			dp[j][k]=max(dp[j][k],dp[j-1][k-t[i]]+v[i]);
		}
		if(dp[m][l]<0)
		dp[m][l]=0;
		printf("%d\n",dp[m][l]);
	}
	return 0;
 }  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值