B - Text Reverse HDU - 1062

题目

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca
Sample Output
hello world!
I’m from hdu.
I like acm.

题目意思好理解的,目前我有两种办法,一种是字符输入,一种是字符串输入;

字符串输入,运用getline(cin,s);

#include<iostream>//字符串输入 
#include<stack>
#include<algorithm>
#include<string>
using namespace std; 
int main(){
	int T;
	cin >> T;
	getchar();//消去空格,这里需要格外注意 
	stack<char> st;
	while(T--){
		string s;
		getline(cin,s);//输入一行 
		for(int i=0;i<s.size();i++){
			while(s[i]!=' '&&s[i]!='\0'){
				st.push(s[i]);
				i++;
			}
			while(!st.empty()){
				printf("%c",st.top());
				st.pop();
			}
			if(s[i]==' ') cout << ' ';
		}
		cout << '\n';
	}
	return 0;
}

字符输入,也有两种

第一种,两次循环

#include<iostream>
#include<stack>
#include<algorithm>
#include<string>
using namespace std; 
int main(){
	char ch;
	int T;
	cin >> T;
	getchar();
	while(T--){
		stack<char> st;
		while(1){//判断输入的字符 
			ch=getchar();//注意
			if(ch==' '||ch==EOF||ch=='\n'){
				while(!st.empty()){
					printf("%c",st.top());
					st.pop();
				}
				if(ch==EOF||ch=='\n') break;
				else cout << ' ';
			}	
			else st.push(ch);				
		}	
		cout << '\n';
	} 
	return 0;
}

一次性结束,只有一次循环

#include<iostream>
#include<stack>
#include<algorithm>
#include<string>
using namespace std; 
int main(){
	char ch;
	int T;
	cin >> T;
	getchar();
	stack<char> st;
	while(1){//判断输入的字符 
		ch=getchar();
		if(ch==' '||ch==EOF||ch=='\n'){
			while(!st.empty()){
				printf("%c",st.top());
				st.pop();
			}
			if(ch==EOF) break;
			else if (ch=='\n') cout << '\n'; 
			else cout << ' ';
		}	
		else st.push(ch);				
	}	
	return 0;
}

我偏向一第一种做法

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值