Text Reverse(字符串反转,文本逆置)

题目:
Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

Hint
Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.

题解:
首先,这不是一个简单的字符串逆置,否则只需调用strrev() 函数即可;它需要考虑到哪里有空格,按空格分开,分别逆置。
此时,我们用temp数组来保存空格前的字符串,再实现temp的逆置,最终实现全部逆置。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	char str[1001],temp[1001];
	int t;
	int j=0,len=0;
	cin>>t;
	getchar();		//吸收换行 
	while(t--)
	{
		gets(str);
		len=strlen(str);
		for(int i=0;i<=len;i++)
		{
			if(str[i]==' '||str[i]=='\0')
			{
				j=0;			
				//j=0必须要有,每次遇到空格后 输出上一个temp,下一个置零重新待读入 
				
				strrev(temp);	//字符串逆置 
				if(str[i]==' ')
				{
					printf("%s ",temp);
				}
				else
				{
					printf("%s",temp);
				}
				temp[i]='\0';
			}
			else
			{
				//将空格前的字符拷贝到temp里 
				temp[j++]=str[i];
				//等价于 temp[j]=str[i];j++; 
			}
			temp[j]='\0';
		}
		printf("\n");	
	}
	return 0;
}

补充(strrev 函数):

#include <string.h>
#include <stdio.h>

int main()
{
    char str[100]="welcome to my website!";
    char *strtemp;

    strtemp=strrev(str);   //实现字符串反序

    printf("The string strtemp reversed is:   %s  ",strtemp);

    return 0;
}

输出的结果是:
The string strtemp reversed is: !etisbew ym ot emoclew

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值