题目:
本题的目标很简单,就是判断一个给定的正整数是否素数。
输入格式:
输入在第一行给出一个正整数N(<=10),随后N行,每行给出一个小于231的需要判断的正整数。
输出格式:
对每个需要判断的正整数,如果它是素数,则在一行中输出“Yes”,否则输出“No”。
输入样例:2 11 111输出样例:
Yes No
思路:
简单说一个素数,素数就是质数,指除了1和本身两个因数外,再也没有别的因数。不包含1。
代码:
import java.util.Scanner;
public class Main {
public static boolean p(long a){
int count = 0;
if(a==2||a==3){
return true;
}else if(a>3){
for(int i=1;i<=(int)Math.sqrt(a);i++){
if(a%i == 0){
count ++;
}
}
}
if(count == 1)
return true;
else
return false;
}
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
long[] a = new long[n];
for(int i=0;i<n;i++){
a[i] = sc.nextLong();
}
for(int i=0;i<n;i++){
if(p(a[i]) == true){
System.out.println("Yes");
}else{
System.out.println("No");
}
}
}
}