woj1005 - Holding Animals

Description
The total available floor space on the ark would have been over 100,000 square feet, which would be more floor space than in 20 standard sized 
basketball courts. But in our story, we assume that the land dwelling air breathing animals is so many that the Ark can't contain all of them. 

We know that the size of each kind of animal is different and the God has his own favorite. The God assigns each kind of animal a point to 
show his favorite, and then lists points of every kind of animal to Noah. Noah must let some kinds of animals into the Ark and refuse 
the others to maximize the total points. Noah cries for he doesn't know computer programming. 

It 's an easy problem for you,right? So,rescue Noah!
Input
There will be multiple test cases. For each test case,the first line contains an integer n(n<=100) representing the number of species of the land 
dwelling air breathing animals all over the world.
In the next n lines,there will be two integers in each line,separated by a single space,where the first integer shows the size of a kind of animal 
and the second integer shows the point. The size and the point for all the animals will not exceed 10000.
The last line contains an integer s(s <= 100,000) indicating the size of Noah's Ark.
Output
For each test case,you should output a line that contains a single integer to describe the maximal point Noah can get.
Sample Input
2
10 20
20 30
30
3
10 20
30 30
20 20
30
Sample Output
50
40

背包问题,dp[j] = max(dp[j], dp[j-w[i]] + va[i]);

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include <iostream>   
#include <cstring> 

int max(int n, int m)
{
    int t;
    t = n > m ? n : m;
    return(t);
} 

int main()
{
    int dp[100005];
    int m, t, w[105], va[105];
    while((scanf("%d",&m)) != EOF)
    {
          int i,j, p, q;
          memset(dp, 0, sizeof(dp)); 
          for(j = 0; j < m; j++)
          {
                scanf("%d%d",&w[j],&va[j]);
          }
          scanf("%d", &t); 
          for(i = 0; i < m; i++)
          {
                for(j = t; j > -1; j--)
                {
                      if(j >= w[i])
                      { 
                            dp[j] = max(dp[j], dp[j-w[i]] + va[i]);
                      }
                }
            }
            printf("%d\n",dp[t]); 
    } 
    return 0;
} 
         

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值