poj1125(Floyd)最短路问题

http://poj.org/problem?id=1125

Stockbroker Grapevine
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 20278Accepted: 10980

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

题意:
首先,题目可能有多组测试数据,每个测试数据的第一行为经纪人数量N(当N=0时,输入数据结束),然后接下来N行描述第i(1<=i<=N)个经纪人与其他经纪人的关系(教你如何画图)。每行开头数字M为该行对应的经纪人有多少个经纪人朋友(该节点的出度,可以为0),然后紧接着M对整数,每对整数表示成a,b,则表明该经纪人向第a个经纪人传递信息需要b单位时间(即第i号结点到第a号结点的孤长为b),整张图为有向图,即弧Vij 可能不等于弧Vji(数据很明显,这里是废话)。当构图完毕后,求当从该图中某点出发,将“消息”传播到整个经纪人网络的最小时间,输出这个经纪人号和最小时间。最小时间的判定方式为——从这个经纪人(结点)出发,整个经纪人网络中最后一个人接到消息的时间。如果有一个或一个以上经纪人无论如何无法收到消息,输出“disjoint”(有关图的连通性,你们懂得,但据其他同学说,POJ测试数据中不会有,就是说,你不判定,一样能过,题目数据够水的)。
以第一样例为例:
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2

总共3个经纪人,一号经纪人可向2个人传递信息,向2号传递所需时间为4分钟,向3号
传递需5分钟。二号经纪人可向2个人传递信息,向1号需2分钟,向3号需6分钟。三号
经纪人可向2人传递信息,向1号需2分钟,向2号需2分钟。(以上阿拉伯数字即为对
应数据)
将图画出,很容易得出,从3号出发,网络中最后一个得到消息的,需2分钟(可以同时向多人传递,有点不合情理)。所以输出为 3 2。

问题重述
描述,
 
  股票经纪人已知的币值的谣言。你一直在简约的开发方法间传播,指责给雇主股票的战术优势在股票市场。为最大的效果,你必须散播谣言最快的方式。
 
  不幸的是,对于你,股票经纪人只相信信息来源来自他们的“信任”,这意味着你不得不考虑结构的接触时的谣言。它需要一定的时间为一个特定的经纪人通过传闻中每一个人在他的同事。你的任务是将编写一个程序,告诉你哪个证券选择作为起始点的谣言,以及要花多少时间,对传闻传遍整个证券经纪人的社区。这就是以所需时间的人,也是最后一个接收信息。
  输入,
 
  你的程序将输入的数据为不同的股票经纪人。每一套始于一个符合数量的股票经纪人。这是一条线为每一个经纪人所包含的人数比他们有接触,这些人是,时间为他们传递信息的每一个人。格式的每一个经纪人线如下:线从多个联系人(n),其次是n成对的整数,一对每次触球。第一个数字列出每一对参照联系(如“1”,指人之一(套),其次是时间在几分钟内送到传递信息的那个人。没有特别的标点符号的规则或间距。
 
  每个人都是数的数字1到的股票经纪人。时间来传递信息将在1到10分钟(含1年),而且这个数目的接触会范围从0到一个小于数量的股票经纪人。股票的数量将范围从1到100。输入是一套股票经纪人含有0(零)的人。
 
 
  输出
 
  对于每一组数据,你的程序必须输出一行中含有的人,结果以最快的信息传输,多长时间过去的人将得到任何信息后,你给这个人以整数分。
  它可能是你的程序将会收到一个网络连接的排除有些人,如某些人可能是遥不可及的。如果你的程序检测这样的断网,简单的输出信息"凸”。注意时间来传递信息从一个人给某人不一定是相同的时间把它从乙到,如果这种传输是可能的。
 
表示离散没学好亚历山大啊。。
离散离散数学上的知识感觉太少了。考试能过就行了,平时还是要把时间花在课外扩张知识上面。。。这题完全是参考别人的代码的,题意理解了很久啊。不过终于理解了集训时候不理解的最大值里求最小值的原因。
#include<iostream>
using namespace std;
const int maxn=100;
int dis[maxn+10][maxn+10];//存放最短路
int n;//人数
int locate;//保存最短路的下标
void floyd()//floyd算法
{
 for(int k=1;k<=n;k++)//顺序不能乱
 {
  for(int i=1;i<=n;i++)
  {
   for(int j=1;j<=n;j++)
   {
    if(dis[i][j]>dis[i][k]+dis[k][j])
     dis[i][j]=dis[i][k]+dis[k][j];
   }
  }
 }
}
void Min()
{
 int i,j;
 int maxn,minn=100000;
 for(i=1;i<=n;i++)
 {
  maxn=0;//从i开始的最长路
  for(j=1;j<=n;j++)
  {
   if(i!=j&&dis[i][j]>maxn)
    maxn=dis[i][j];
  }
  if(maxn<minn)//最长路中求最短
  {
   locate=i;
   minn=maxn;
  }
 }
 (minn<10000000)?printf("%d %d\n",locate,minn):printf("disjoint\n");//没有路径到达就用无穷表示
}
int main()
{
 int i,j,k,p,q;
 while(scanf("%d",&n),n)
 {
  //用floyd之前要初始化(接近无穷)
  for(i=1;i<=n;i++)
  {
   for(j=1;j<=n;j++)
    dis[i][j]=100000000;
  }
  //输入数据;
  for(i=1;i<=n;i++)
  {
   scanf("%d",&k);
   for(j=1;j<=k;j++)
   {
    scanf("%d %d",&p,&q);
    dis[i][p]=q;//i到p的长度为q
   }
  }
  floyd();
  Min();
 }
 return 0;
}
 
 
 
代码2:
#include<stdio.h>
#include<string.h>
int dis[101][101];
int pos,min,max;
int n,p,q,m;
void floyd()
{
  int i,j,k;
  for(i=1;i<=n;i++)
  {
    for(j=1;j<=n;j++)
    {
      for(k=1;k<=n;k++)
      {
        if(dis[j][k]>dis[j][i]+dis[i][k])
          dis[j][k]=dis[j][i]+dis[i][k];
      }
    }
  }
}
void minx()
{
  int i,j;
  int pos;
  int min=1000000;
  for(i=1;i<=n;i++)
  {
    max=0;
 
    for(j=1;j<=n;j++)
    {
      if(i!=j&&dis[i][j]>max)
        max=dis[i][j];
    }
    if(min>max)
    {
      min=max;
      pos=i;
   
  }
  if(min==1000000)
    printf("disjoint\n");
  else
    printf("%d %d\n",pos,min);
}
int main()
{
  //int n;
  while(scanf("%d",&n)!=EOF)
  {
    if(n==0)
      break;
    int i,j;
    for(i=1;i<=n;i++)
    {
      for(j=1;j<=n;j++)
        dis[i][j]=10000000;
    }
    for(i=1;i<=n;i++)
    {
      scanf("%d",&p);
      for(j=1;j<=p;j++)
      {
        scanf("%d %d",&m,&q);
        dis[i][m]=q;
      }
    }
    floyd();
    minx();
    //printf("%d %d\n",pos,min);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值