poj3100

http://poj.org/problem?id=3100

Root of the Problem
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10385Accepted: 5560

Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input

The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output

For each pair B and N in the input, output A as defined above on a line by itself.

Sample Input

4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0

Sample Output

1
2
3
4
4
4
5
16

Source

题意给你两个数b,n求一个数a使得a的n次方最接近b。。。水过。。pow()用的时候要注意格式啊
在math.h中,函数pow有三种重载形式:
long double pow(long double,int)
float pow(float,int)
double pow(double,int)
对于所给的参数int,int,编译器无法判断应该匹配哪个函数,因此报错
可以将代码改为pow(10.0,(int)i)
#include<stdio.h>
#include<math.h>
int main()
{
        int b,n;
        while(scanf("%d %d",&b,&n),b,n)
        {
                int i;
                for(i=1;i<=b;i++)
                {
                        if(pow((float)i,(int)n)==b)
                        {
                                printf("%d\n",i);
                                break;
                        }
                        else if(pow((float)i,(int)n)<b&&pow((float)i+1,(int)n)>b)
                        {
                                if(abs(pow((float)i,(int)n)-b)<abs(pow((float)i+1,(int)n)-b))
                                {
                                        printf("%d\n",i);
                                        break;
                                }
                                else
                                {
                                        printf("%d\n",i+1);
                                        break;
                                }
                        }
                }
        }
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值