(未)poj1915(bfs)

http://poj.org/problem?id=1915

Knight Moves
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 17850Accepted: 8147

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
(未)poj1915(bfs)

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

Source

TUD Programming Contest 2001, Darmstadt, Germany
题目大意:输入n表示有n组测试数据,每组数据先输入一个m,表示矩阵的大小为m*m,然后给出一个士兵的起点和终点,,士兵可以按照如图所示的方向移动,要求输出将士兵从起点移到终点的最小步数。
可以参考白书108。。感觉bfs比dfs难理解。。。
  #include<stdio.h>
#include<string.h>
int graph[300][300],step[300][300];
int m;
int p[8]={-2,-1,1,2,2,1,-1,-2};
int q[8]={1,2,2,1,-1,-2,-2,-1};
int qx[90001],qy[90001];
void bfs(int x,int y)
{
        int nx,ny,i;
        int front=0,rear=0; qx[rear]=x;
        qy[rear++]=y;
        graph[x][y]=1;
        step[x][y]=0;
        while(front<rear)
        {
                x=qx[front];
                y=qy[front++];
                for(i=0;i<8;i++)
                {
                        nx=x+p[i];
                        ny=y+q[i];
                        if(nx>=0&&nx<m&&ny>=0&&ny<m&&!graph[nx][ny])
                        {
                                graph[nx][ny]=1;
                                step[nx][ny]=step[x][y]+1;
                                qx[rear]=nx;
                                qy[rear++]=ny;
                        }
                }
        }
}
int main()
{
        int n,sx,sy,ex,ey;
        scanf("%d",&n);
        while(n--)
        {
                scanf("%d",&m);
                memset(graph,0,sizeof(graph));
                memset(step,0,sizeof(step));
                scanf("%d %d",&sx,&sy);
                scanf("%d %d",&ex,&ey);
                if(sx==ex&&sy==ey)
                {
                        printf("0\n");
                        continue;
                }
                bfs(sx,sy);
                printf("%d\n",step[ex][ey]);
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值