uva10115

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1056

10115 - Automatic Editing

Time limit: 3.000 seconds

Problem E: Automatic Editing

Source file:autoedit.{c, cpp,java, pas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-bystring. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop
题意:将列表第一列的字符串不断换成第二列的字符串,直到将所给的整个句子中所有出现的第一列字符串全部换掉为止,然后再进行下一个字符串的替换。
strstr(str1,str2).找出str2字符串在str1字符串中第一次出现的位置(不包括str2的串结束符)。  
代码:
#include<stdio.h>
#include<string.h>
int main()
{
 int T,i,l;
 char st1[50][80],st2[50][80],st[500]={'\0'},_st[500];
 while(scanf("%d",&T)!=EOF)//输入测试数据有多少组
 {
  if(T==0)//T==0表示整个结束
   return 0;
  getchar();//吸收换行
  for(i=0;i<T;i++)
  {
   gets(st1[i]);//输入字符串1
   gets(st2[i]);//输入字符串2
  }
  gets(st);//输入字符串
  for(i=0;i<T;i++)
  {
   if(strstr(st,st1[i])!=NULL)//
   {
    char *p=strstr(st,st1[i]);//找出str2字符串在str1字符串中第一次出现的位置(不包括str2的串结束符)
    l=strlen(st1[i]);//求出st1[i]的长度
    strcpy(_st,p+l);//复制从p+l指针后面的字符到_st中保存
    *p='\0';//
    //puts(_st);
    strcat(st,st2[i]);//把str2[]链接到st中去将要替换的部分进行替换(将要替换后边的字符串也覆盖掉了)
    strcat(st,_st);//把_st链接到st中。将暂存的字符串补上
    i--;//不理解**************
    //break;
   }
  }
  puts(st);
 }
 return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值