uva10815

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1756

 

10815 - Andy's First Dictionary

Time limit: 3.000 seconds

Problem B: Andy's First Dictionary

Time limit: 3 seconds


uva10815

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

Joke and image taken from the Web
 
题意:输入一系列的单词,把所有的单词按照字典序输出。。。有单词重复的只输出一次。。
和白书79页很像。。。如代码2
 
代码1
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<ctype.h>
#include<stdlib.h>
using namespace std;
char result[1000001][210];
char word[1000000][210],str[210];
int cmpstring(const void*a,const void*b)
{
 return strcmp((char*)a, (char*)b);
}
int main()
{
 int cnt=0;
 int i;
 while(gets(str))
 {
  int len=strlen(str);
  for(i=0;i<len;i++)
  {
   if(isalpha(str[i]))
   {
    char ch[100];
    int t=0,j;
    for(j=i;j<len;j++)
    {
     if(isalpha(str[j]))
     {
      ch[t++]=tolower(str[j]);
     }
     else break;
    }
    ch[t]='\0';
    strcpy(word[cnt++],ch);
    i=j;
   }
   else i++;
  }
 }
 int num=0;
 for(i=0;i<cnt;i++)
 {
  int flag=0;
  for(int j=i+1;j<cnt;j++)
   if(strcmp(word[i],word[j])==0)
   {
    flag=1;
    break;
   }
  if(flag==0)
  {
   strcpy(result[num],word[i]);
   num++;
  }
 }
 qsort(result,num,sizeof(result[0]),cmpstring);
 for(i=0;i<num;i++)
  cout<<result[i]<<endl;
 return 0;
}
 
代码2(自己比较喜欢)
#include<stdio.h>
#include<stdlib.h>
#include<ctype.h>
#include<string.h>
char d[1000010][210]={'\0'};
int n=0,len=0;
int cmp_string(const void*_a,const void*_b)//字符串比较函数
{
 char *a=(char*)_a;
 char *b=(char*)_b;
 return strcmp(a,b);
}
int main()
{
 char ch;
 while((ch=getchar())!=EOF)//直到读到文件结束;
 {
  if(isalpha(ch))//如果是英文字母一律把它转化成小写字母并且保存在数组d[][]中
  {
   d[n][len++]=tolower(ch);
  }
  else if(isalpha(d[n][0]))//*************不理解
  {
   d[n++][len]='\0';
   len=0;
  }
  
 }
 qsort(d,n,sizeof(d[0]),cmp_string);//把所有的单词排序
 for(int i=0;i<n;i++)
 {
  if(strcmp(d[i],d[i+1]))//相同的单词不输出(相同的单词肯定是相邻的)
   printf("%s\n",d[i]);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值