http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1108
10167 - Birthday Cake
Time limit: 3.000 seconds
Problem G. Birthday Cake |
Background
Lucy and Lily are twins. Today is their birthday. Mother buys a birthday cake for them.Now we put the cake onto a Descartes coordinate. Its center is at (0,0), and the cake's length of radius is 100.
There are 2N (N is a integer, 1<=N<=50) cherries on the cake. Mother wants to cut the cake into two halves with a knife (of course a beeline). The twins would like to be treated fairly, that means, the shape of the two halves must be the same (that means the beeline must go through the center of the cake) , and each half must have N cherrie(s). Can you help her?
Note: the coordinate of a cherry (x , y) are two integers. You must give the line as form two integers A,B(stands for Ax+By=0), each number in the range [-500,500]. Cherries are not allowed lying on the beeline. For each dataset there is at least one solution.
Input
The input file contains several scenarios. Each of them consists of 2 parts: The first part consists of a line with a number N, the second part consists of 2N lines, each line has two number, meaning (x,y) .There is only one space between two border numbers. The input file is ended with N=0.
Output
For each scenario, print a line containing two numbers A and B. There should be a space between them. If there are many solutions, you can only print one of them.
Sample Input
2 -20 20 -30 20 -10 -50 10 -5 0
Sample Output
0 1
题意:一个蛋糕上有2*n个cherries ,问怎样切蛋糕可以把cherries 平分。。
数据不是很大可以直接暴力
疑点: the shape of the two halves must be the same (that means the beeline must go through the center of the cake) , and each half must have N cherrie(s). 不是还要把蛋糕也平分?
#include<stdio.h>
#include<string.h>
#define maxn 110
int x[maxn],y[maxn];
int main()
{
int n,ok;
while(scanf("%d",&n)!=EOF)
{
int i,j,k;
if(n==0)
break;
for(i=0;i<2*n;i++)
scanf("%d %d",&x[i],&y[i]);樱桃的坐标
for(i=-500;i<=500;i++)//
{
for(j=-500;j<=500;j++)
{
ok=0;
int c1=0,c2=0;
for(k=0;k<2*n;k++)
{
if(i*x[k]+j*y[k]>0)//cheeses在直线的上方
c1++;
else if(i*x[k]+j*y[k]<0)//cheese是在直线 的下方
c2++;
else if(i*x[k]+j*y[k]==0)//cheeses在只直线上(这种情况不允许)
break;
}
if(c1==c2&&c1==n)//直线两端的cheeses相同
{
ok=1;
printf("%d %d\n",i,j);
break;
}
}
if(ok)
break;
}
}
return 0;
}