0.85poj3041(匈牙利算法)

http://poj.org/problem?id=3041

Asteroids
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10121Accepted: 5462

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

 
#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 10010
int map[502][502];
int vis[MAXN],flag[MAXN];
int n,m;
bool dfs(int a)//寻找从a出发的对应项出的可增广路
{
  int i;
  for(i=1;i<=n;i++)//从邻接表中列举a能关联到顶点i
  {
    if(map[a][i]&&!vis[i])//i不在增广路上,a到i相邻(有边) 且 节点i未被搜索 
    {
      vis[i]=1;//把i加入增广路;
      if(flag[i]==0||dfs(flag[i]))//i是未盖点或者从i的对应项出发有可增广路
      {
        flag[i]=a;//修改i的对应项为a;
        return true;//则从i的对应项出有可增广路,返回true
      }
    }
  }
  return false;
}
int main()
{
  int i;
  while(cin>>n>>m)//n图的大小n*n,m个点(行星)
  {
    memset(map,0,sizeof(map));//第一步置map为空
    for(i=1;i<=m;i++)
    {
      int x,y;
      cin>>x>>y;
      map[x][y]=1; //相邻节点标记  
    }
    memset(flag,0,sizeof(flag));
    int result=0;
    for(i=1;i<=n;i++)//void 匈牙利hungary()
    {
      memset(vis,0,sizeof(vis));
      if(dfs(i))//则从i的对应项出有可增广路
        result++;//匹配数++;
    }
    cout<<result<<endl;//输出匹配数;
  }
  return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值