1poj2299(串,归并排序)

http://poj.org/problem?id=2299

Ultra-QuickSort
Time Limit: 7000MSMemory Limit: 65536K
Total Submissions: 27554Accepted: 9860

Description

1poj2299(串,归并排序)In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

题意:求数组元素的逆序数个数。直接用暴力(冒泡排序)tle..网上有很好的解答
代码
//代码1:tle
#include<stdio.h>
#include<string.h>
int a[500010];
int main()
{
  int n;
  while(scanf("%d",&n)!=EOF)
  {
    int i,j;
    if(n==0)
      break;
    int count=0;
    memset(a,0,sizeof(a));
    for(i=0;i<n;i++)
      scanf("%d",&a[i]);
    for(i=0;i<n;i++)
    {
      for(j=0;j<i;j++)
      {
        if(a[j]>a[i])
        {
          int t=a[i];
          a[i]=a[j];
          a[j]=t;
          count++;
        }
      }
    }
    printf("%d\n",count);
  }
  return 0;
}
 
代码2:AC
#include<stdio.h>
#define MAXN 500001
int n,a[MAXN],t[MAXN];
__int64 sum;
void Merge(int l,int m,int r)
{
  int p=0;// p指向输出区间
  int i=l,j=m+1;// i、j指向2个输入区间
  while(i<=m&&j<=r)
  {
    if(a[i]>a[j])//前面一个元素比后面一个元素大满足逆序sum累加.取关键字小的记录转移至输出区间
    {
      t[p++]=a[j++];// a[i]后面的数字对于a[j]都是逆序的
      sum+=m-i+1;
    }
    else
      t[p++]=a[i++];
  }
  while(i<=m)t[p++]=a[i++];// 将非空的输入区间转移至输出区间
  while(j<=r)t[p++]=a[j++];
  for(i=0;i<p;i++)// 归并完成后将结果复制到原输入数组
    a[l+i]=t[i];
}
void MergeSort(int l,int r)
{
  int m;
  if(l<r)
  {
    m=(l+r)/2;// 将长度为n的输入序列分成两个长度为n/2的子序列
    MergeSort(l,m);// 对两个子序列分别进行归并排序
    MergeSort(m+1,r);
    Merge(l,m,r);//将2个排好的子序列合并成最终有序序列
  }
}
int main()
{
  int i;
  while(scanf("%d",&n)!=EOF)
  {
    if(n==0)
      break;
    sum=0;
    for(i=0;i<n;i++)
    {
      scanf("%d",&a[i]);
    }
    MergeSort(0,n-1);//从0到最后一个元素n-1
    printf("%I64d\n",sum);
  }
  return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值