poj1650(枚举)

http://poj.org/problem?id=1650

Integer Approximation
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4945Accepted: 1595

Description

The FORTH programming language does not support floating-point arithmetic at all. Its author, Chuck Moore, maintains that floating-point calculations are too slow and most of the time can be emulated by integers with proper scaling. For example, to calculate the area of the circle with the radius R he suggests to use formula like R * R * 355 / 113, which is in fact surprisingly accurate. The value of 355 / 113 ≈ 3.141593 is approximating the value of PI with the absolute error of only about 2*10 -7. You are to find the best integer approximation of a given floating-point number A within a given integer limit L. That is, to find such two integers N and D (1 <= N, D <= L) that the value of absolute error |A - N / D| is minimal.

Input

The first line of input contains a floating-point number A (0.1 <= A < 10) with the precision of up to 15 decimal digits. The second line contains the integer limit L. (1 <= L <= 100000).

Output

Output file must contain two integers, N and D, separated by space.

Sample Input

3.14159265358979
10000

Sample Output

355 113

Source

Northeastern Europe 2001, Far-Eastern Subregion

题意:在L(1 <= L <= 100000)的范围内找N和D使得|A-N/D|的误差最小,看L的数据范围1 <= L <= 100000,时间1S可以直接暴力。

#include<iostream>
#include<cmath>
double minx=100000;
using namespace std;
int main()
{
 double A;
 int N,D,L;
 while(scanf("%lf %d",&A,&L)!=EOF)
 {
  int i=1,j=1;
  while(i<=L&&j<=L)//直接在整个L上遍历
  {
   double t=fabs((double)j/(double)i-A);
   if(t<minx)
   {
    D=i;
    N=j;
    minx=t;
   }
   if((double)j/(double)i>=A)i++;//比A大,分母+1
   else if((double)j/(double)i<A)j++;//比A小,分子+1
  }
  printf("%d %d\n",N,D);
 }
 return 0;
}

 

网上还有一种很好的算法二分法,感觉这才是王道,很多情况这种算法都是适用的而不要为TLE而担心。。自己载在这上面不是一两次了。。。下面这两种解题的方法还不会代码不大明白以后在仔细研究

http://www.cnblogs.com/rainydays/archive/2011/09/29/2195088.html

 

http://hi.baidu.com/findthegateopen/blog/item/f95e4fdb469ce3d3b6fd489f.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值