poj2499(K短路)

http://poj.org/problem?id=2499

Binary Tree
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4894Accepted: 2297

Description

Background
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:
  • The root contains the pair (1, 1).
  • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

Input

The first line contains the number of scenarios.
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*10 9) that represent
a node (i, j). You can assume that this is a valid node in the binary tree described above.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

Sample Input

3
42 1
3 4
17 73

Sample Output

Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

Source

题意:这题从做的人来看绝不是大都数人用一个数学公式就完事了。出题人肯定也不是这么想的。只怪现在牛人太多,很多牛人曾经都获得过什么奥数奖的,坑爹啊。这题网上说是K短路,见识了。。
题意:规定根节点(1,1),输出(a,b)求从(1,1)到(a,b)最少要向左几次,向右几次。规则如下:
  • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)
  • 比如:现在根节点是(1,1),那么下一步要么是(2,1)||(1,2)。如果选择的是(2,1)那么在下一步就是
  • (3,1)||(2,3)。。。。求从(1,1)到输出点最小向左走的步数&&最小向右走的步数。
  • 公式倒推回去,可以发现只要是向左走的必然现在的a>b,向右走的现在必然b>a所以根据现在的(a,b)判断上一步...。。好了a>b就一直向左。。。知道b>a,就一直向右,还一个注意点是当出现1的时候要特殊处理一下这时候只能是一直向左到(1,1)||一直向右到(1,1)。。
  • 有个很好的例子假设有8个苹果,一次拿2个,拿一次剩6个,再拿一次剩4个……拿了4此之后没了。同时,8/2=4,所以……这是diss里的。。嘻嘻解释的太好了。。。
  • #include<stdio.h>
  • void TravelCount(int &l,int &r,int a,int b)
    {
    while(a!=1||b!=1)
    {
    if(a==1)
    {
    r+=b-a;
    break;
    }
    if(b==1)
    {
    l+=a-b;
    break;
    }
    if(a>b)
    {
    l+=a/b;
    a-=b*(a/b);
    }
    else
    {
    r+=b/a;
    b-=a*(b/a);
    }
    }
    }
    int main()
    {
    int t,a,b,l,r,i=1;
    scanf("%d",&t);
    while(t--)
    {
    scanf("%d%d",&a,&b);
    l=r=0;
    TravelCount(l,r,a,b);
    printf("Scenario #%d:\n",i++);
    printf("%d %d\n\n",l,r);
    }
    return 0;
    }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值