http://poj.org/problem?id=2524
Ubiquitous Religions
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 17626 | Accepted: 8578 |
Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9 1 2 1 3 1 4 1 5 1 6 1 7 1 8 1 9 1 10 10 4 2 3 4 5 4 8 5 8 0 0
Sample Output
Case 1: 1 Case 2: 7
Hint
Huge input, scanf is recommended.
Source
代码:
//并查集主要操作1初始化2查找3合并
#include<stdio.h>
int father[50001],num[50001];//num存储节点所在集合元素的个数father[]存储节点的父节点
void Make_Set(int x)//初始化集合(把每个点所在集合初始化为其自身)
{
father[x]=x;
num[x]=0;
}
int Find_Set(int x)//2查找x元素所在的集合,回溯时压缩路径
{
if(x!=father[x])
{
father[x]=Find_Set(father[x]);//路劲压缩
}
return father[x];
}
void Union_Set(int a,int b)/// 3合并a,b所在的集合
{
if(a==b)// 如果两个元素在同一个集合则不需要合并
return;
if(num[a]<=num[b])//将小集合合并到大集合中,更新集合个数
{
father[a]=b;
num[b]+=num[a];
}
else
{
father[b]=a;
num[a]+=num[b];
}
}
int main()
{
int n,m;
int t=1;
while(scanf("%d %d",&n,&m)!=EOF)
{
if(n==0&&m==0)
break;
int i;
for(i=0;i<n;i++)//将每个节点作为一个集合
{
Make_Set(i);
}
int a,b;
for(i=0;i<m;i++)
{
scanf("%d %d",&a,&b);
a=Find_Set(a);//查找a所在的集合
b=Find_Set(b);//查找b所在的集合
if(a!=b)///不在同一集合则合并,n减1
{
n--;
Union_Set(a,b);
}
}
printf("Case %d: %d\n",t++,n);
}
return 0;
}
int father[50001],num[50001];//num存储节点所在集合元素的个数father[]存储节点的父节点
void Make_Set(int x)//初始化集合(把每个点所在集合初始化为其自身)
{
}
int Find_Set(int x)//2查找x元素所在的集合,回溯时压缩路径
{
}
void Union_Set(int a,int b)/// 3合并a,b所在的集合
{
}
int main()
{
}