并查集简单题目其一

How Many Tables
Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

这道题的大致意思是:给你T组数据,每组有m行,1~n编号的桌子,每行给你a和b,说明a和b能够一起坐在一起,可以传递,即a和b能坐在一起,b和c能坐在一起,a和c也能坐在一起。问你需要几张桌子?
思路:用并查集去做,最后判断它的祖先结点是否是他自己,如果是,则数量加一。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1005;
int fa[maxn];
int find(int x){
	return x==fa[x]?x:fa[x]=find(fa[x]);
}
void baba(int x,int y){
	int fx=find(x);
	int fy=find(y);
	fa[fx]=fa[fy];
}
int main(){
	int t;
	cin>>t;
	while(t--){
		int n,m;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++){
			fa[i]=i;
		} 
		for(int i=1;i<=m;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			baba(a,b);
		}
		int cnt=0;
		for(int i=1;i<=n;i++){
			if(find(i)==i){
				cnt++;
			}
		}
		cout<<cnt<<endl;
	}
}

Ubiquitous Religions

Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output
Case 1: 1
Case 2: 7

这道题的大致意思与上面一道题差不多,是给你多组数据,1~n的人,m行。在接下来的m行中,每行给你a,b两个编号,代表a,b有相同的信仰,问你,编号1 ~ n的人中共有几个不同的信仰?
解法和上一道题一样,就不多说了。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=5e4+10;
int fa[maxn];
int find(int x){
	return x==fa[x]?x:fa[x]=find(fa[x]);
}
void baba(int x,int y){
	int fx=find(x);
	int fy=find(y);
	fa[fx]=fa[fy];
}
int main(){
	int n,m;
	int cnt=0;
	while(cin>>n>>m&&n+m){
		int a,b;
		for(int i=1;i<=n;i++){
			fa[i]=i;
		}
		for(int i=1;i<=m;i++){
			cin>>a>>b;
			baba(a,b);
		}
		int ans=0;
		for(int i=1;i<=n;i++){
			if(find(i)==i)ans++;
		}
		printf("Case %d: %d\n",++cnt,ans);
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值