6-3 Add Two Polynomials

6-3 Add Two Polynomials (20 分)

Write a function to add two polynomials. Do not destroy the input. Use a linked list implementation with a dummy head node. Note: The zero polynomial is represented by an empty list with only the dummy head node.

Format of functions:

Polynomial Add( Polynomial a, Polynomial b );

where Polynomial is defined as the following:

typedef struct Node *PtrToNode;
struct Node {
    int Coefficient;
    int Exponent;
    PtrToNode Next;
};
typedef PtrToNode Polynomial;
/* Nodes are sorted in decreasing order of exponents.*/  

The function Add is supposed to return a polynomial which is the sum of a and b.

Sample program of judge:

#include <stdio.h>
#include <stdlib.h>
typedef struct Node *PtrToNode;
struct Node  {
    int Coefficient;
    int Exponent;
    PtrToNode Next;
};
typedef PtrToNode Polynomial;

Polynomial Read(); /* details omitted */
void Print( Polynomial p ); /* details omitted */
Polynomial Add( Polynomial a, Polynomial b );

int main()
{
    Polynomial a, b, s;
    a = Read();
    b = Read();
    s = Add(a, b);
    Print(s);
    return 0;
}

/* Your function will be put here */

Sample Input:

4
3 4 -5 2 6 1 -2 0
3
5 20 -7 4 3 1

Sample Output:

5 20 -4 4 -5 2 9 1 -2 0

#include <stdio.h>
#include <stdlib.h>
typedef struct Node *PtrToNode;
struct Node {
    int Coefficient;
    int Exponent;
    PtrToNode Next;
};
typedef PtrToNode Polynomial;

Polynomial Read(){
    Polynomial s = (Polynomial)malloc(sizeof(struct Node));
    int n = 0;
    Polynomial h = s;
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
    Polynomial p1 = (Polynomial)malloc(sizeof(struct Node));
    scanf("%d %d", &p1->Coefficient, &p1->Exponent);
    s->Next = p1;
    p1->Next = NULL;
    s = p1;
    }
    return h;
}

void Print(Polynomial p) {
    p = p->Next;
    while (p) {
        printf("%d  %d  ", p->Coefficient, p->Exponent);
        p = p->Next;
    }
}
Polynomial Add(Polynomial a, Polynomial b);

int main()
{
    Polynomial a, b, s;
    a = Read(); 
    b = Read();
    s = Add(a, b);
    Print(s);
    return 0;
}    
    Polynomial Add(Polynomial a, Polynomial b) {
        if (!a->Next) return b;
        if (!b->Next)   return a;
        a = a->Next;
        b = b->Next;
        int sum = 0;
        int ans[100000] = {0};
        while (a) {
            ans[a->Exponent] += a->Coefficient;
            if (a->Exponent > sum)
                sum = a->Exponent;
            a = a->Next;
        }
        while (b) {
            ans[b->Exponent] += b->Coefficient;
            if (b->Exponent > sum)
                sum = b->Exponent;
            b = b->Next;
        }
        int flag = 0;
        Polynomial s = (Polynomial)malloc(sizeof(struct Node));    
        Polynomial h = s;
        for (int i = sum; i >= 0; i--) {
            if (ans[i] != 0) {
                Polynomial tp = (Polynomial)malloc(sizeof(struct Node));
                tp->Exponent = i;
                tp->Coefficient = ans[i];
                s->Next = tp;
                tp->Next = NULL;
                s = tp;
                flag = 1;
            }
        }
        if(flag==0){
            Polynomial tp = (Polynomial)malloc(sizeof(struct Node));
            tp->Exponent = 0;
            tp->Coefficient = 0;
            tp->Next = NULL;
            s->Next = NULL;
        }
        return h;
    }

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值