kaldi 一些错误

1)“awk:line12:function gensub never defined

       解决: sudo apt-get install gawk


2)“Error: and run extras/install_irstlm.sh”

      怎么回事呢?因为这个例程建立语言模型是用irstlm工具建立的,但是在最新版本的kaldi里面,irstlm不是默认编译的。首先进入kaldi目录下的tools/extras目录,执行install_irstlm.sh脚本。安装完成以后,  目录下出现irstlim目录。由于timit例程里面的引用irstlm工具的路径是tools目录,所以把这个目录拷贝到tools/目录下。回到egs/timit/s5目录,执行./run.sh脚本,于是timit例程就跑起来了。


3)Error: the IRSTLM is not available or compiled

    解决:cd kaldi-master/tools/extras

          ./install_irstlm.sh

          将生成的env.sh复制到tools文件夹下即可。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lansetiankong2104/article/details/51538183
文章标签: kaldi错误
个人分类: 语音识别
下一篇在Ubuntu系统下装Win7并引导双系统
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭