POJ1469--COURSES--二分图匹配

COURSES

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27890 Accepted: 10617

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 


  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

Southeastern Europe 2000

二分图入门题。

P门课N学生,问每个学生能不能选且仅选一门唯一的课。

注意:二分图是无向图,但是二分图中的g数组只保存从左边点集到右边点集的边.即g[i]==j,只代表左边i点与右边j点连接了一条无向边,不代表右边i点也与左边j点连了边. 以上结论一定要牢记.

       因为只有课与学生之间存在边,所以该图可以看成是左边有P个点,右边有N个点的二分图.

       又由于我们想使得课与学生连的边最多且每个学生只能连一门课,每门课也只能有一个学生连接(即每个学生或每门课最多只有一条边依附).所以这就是一个匹配问题且是最大匹配.

       现在要求这个图的最大匹配,看看能否该最大匹配边数目==P.
参考:https://blog.csdn.net/u013480600/article/details/38589641


#include <algorithm>������ //STLͨ���㷨
#include <bitset>����������//STL�����
#include <cctype>
#include <cerrno>
#include <clocale>
#include <cmath>
#include <complex>�������� //������
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <deque>���������� //STL˫�˶�������
#include <exception>������ //�쳣������
#include <fstream>
#include <functional>������//STL�������㺯���������������
#include <limits>
#include <list>������������//STL���������
#include <map>������������ //STL ӳ������
#include <iomanip>
#include <ios>������������//�������룯���֧��
#include<iosfwd>����������//���룯���ϵͳʹ�õ�ǰ������
#include <iostream>
#include <istream>�������� //����������
#include <ostream>�������� //���������
#include <queue>���������� //STL��������
#include <set>������������ //STL ��������
#include <sstream>��������//�����ַ�������
#include <stack>���������� //STL��ջ������������
#include <stdexcept>������ //��׼�쳣��
#include <streambuf>������//�ײ����룯���֧��
#include <string>����������//�ַ�����
#include <utility>�������� //STLͨ��ģ����
#include <vector>����������//STL��̬��������
#include <cwchar>
#include <cwctype>
#define ll long long
using namespace std;
const int maxn=500+10;

struct Max_Match
{
    int p,n;
    bool g[maxn][maxn];
    bool vis[maxn];
    int left[maxn];

    void init(int p,int n)
    {
        this->p=p;
        this->n=n;
        memset(g,0,sizeof(g));
        memset(left,-1,sizeof(left));
    }

    bool match(int u)
    {
        for(int v=1;v<=n;v++)if(g[u][v] && !vis[v])
        {
            vis[v]=true;
            if(left[v]==-1 || match(left[v]))
            {
                left[v]=u;
                return true;
            }
        }
        return false;
    }

    int solve()
    {
        int ans=0;
        for(int i=1;i<=p;i++)
        {
            memset(vis,0,sizeof(vis));
            if(match(i)) ans++;
        }
        return ans;
    }
}MM;

int main()
{
    int n,k,p;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&p,&n);
        MM.init(p,n);
        bool flag=0;
        for(int i=1;i<=p;i++)
        {
            int x;
            scanf("%d",&x);
            if(!x)flag=1;
            while(x--)
            {
                int v;
                scanf("%d",&v);
                MM.g[i][v]=1;
            }
        }
        int ans=MM.solve();
        if(flag||ans!=p)puts("NO");
        else puts("YES");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值